Silverblue Rawhide not being updated since 18/12/2019

Hi all,

Since 18/12/2019 Silverblue Rawhide is not being updated. The last Silverblue Rawhide ISO is from 18/12/2019 also. The output of rpm-ostree status is:

State: busy
AutomaticUpdates: disabled
Transaction: upgrade (download only)
  Initiator: client(id:gnome-software dbus:1.332 unit:gnome-launched-gnome-software-service.desktop-1681.scope uid:1000)
Deployments:
● ostree://fedora:fedora/rawhide/x86_64/silverblue
                   Version: Rawhide.20191218.n.0 (2019-12-18T06:31:05Z)
                BaseCommit: 9db5399a68f64aef1bcde46d2a6df05bb11afa6141fb2ef890cc043f0a47232b
              GPGSignature: Valid signature by 97A1AE57C3A2372CCA3A4ABA6C13026D12C944D0
           LayeredPackages: langpacks-pt

  ostree://fedora:fedora/rawhide/x86_64/silverblue
                   Version: Rawhide.20191218.n.0 (2019-12-18T06:31:05Z)
                BaseCommit: 9db5399a68f64aef1bcde46d2a6df05bb11afa6141fb2ef890cc043f0a47232b
              GPGSignature: Valid signature by 97A1AE57C3A2372CCA3A4ABA6C13026D12C944D0
           LayeredPackages: langpacks-pt

Yeah. We need more people watching the failed composes repo and helping out to identify the issues. I just added a coment here to see if we can investigate and find out what the issue is.

I’m having the same problem.

State: idle
AutomaticUpdates: check; rpm-ostreed-automatic.timer: last run 4h 26min ago
Deployments:
● ostree://fedora:fedora/rawhide/x86_64/silverblue
                   Version: Rawhide.20191218.n.0 (2019-12-18T06:31:05Z)
                BaseCommit: 9db5399a68f64aef1bcde46d2a6df05bb11afa6141fb2ef890cc043f0a47232b
              GPGSignature: Valid signature by 97A1AE57C3A2372CCA3A4ABA6C13026D12C944D0
           LayeredPackages: marco mate-desktop mate-media mate-session-manager paper-icon-theme
                            xorg-x11-drv-amdgpu xorg-x11-fonts-misc zsh

Checking the repodata does not seem to have a problem.
# /var/cache/rpm-ostree/repomd/rawhide-32-x86_64/repodata -> “Most recent data”

206e6dfae5e0f9fc00c6d2bbf5006d50ac0a538280f3d1cbcae6f5fc2d995bce-primary.xml.gz
4f50216010332770b311b2a5ccf00328316cc61b2628292153ca77b8aad988d3-comps-Everything.x86_64.xml
b8cb8b7d7de4b7551a7012225014612bfa2514d7fcf9bb802259ad5122dc55f5-filelists.xml.gz
repomd.xml
# rpm -qv rpm-ostree
rpm-ostree-2019.6.27.g3b8a1ec6-1.fc32.x86_64

# Latest updateable version (rawhide repo):
rpm-ostree-2019.7-2.fc32.x86_64.rpm
# rpm-ostree upgrade --check
1 metadata, 0 content objects fetched; 569 B transferred in 3 seconds
Enabled rpm-md repositories: rawhide
Updating metadata for 'rawhide'... done
rpm-md repo 'rawhide'; generated: 2020-01-27T09:09:39Z
Importing rpm-md... done
No updates available

yes, everyone will have the same problem until the compose is fixed.

1 Like

Current upstream issue to follow with proposed fix: https://github.com/rpm-software-management/libdnf/pull/885

2 Likes

thanks @dustymabe, it’s updating now.