Unable to pull Silverblue Rawhide updates


for a few days - or weeks - rpm-ostree upgrade fails with different errors.
For example:

$ rpm-ostree update 
note: automatic updates (stage) are enabled
Scanning metadata: 1... done
error: While pulling fedora/rawhide/x86_64/silverblue: Writing content object: Ungültige komprimierte Daten
# Something like: Invalid compressed files


$ rpm-ostree update 
note: automatic updates (stage) are enabled
Receiving objects; 0% (2/978) 515.8 kB/s 515.8 kB... done
error: While pulling fedora/rawhide/x86_64/silverblue: Writing content object: Unexpected EOF with 189/240040 bytes remaining

I’m using btrfs and did run a scrub to see if there are any obvious client side fs issues, but I did not find anything.
Thus I wonder if there is something server side which is causing these issues.

Is anybody experiencing similar issues?

FWIW My Fedora Silverblue 37 machine is updating just fine.

1 Like

It turns out that I probably ran into Rebasing Silverblue from Rawhide to 38 or 37 is consistently failing · Issue #420 · fedora-silverblue/issue-tracker · GitHub

$ rpm-ostree override replace  /home/fabiand/Downloads/curl-7.88.1-1.fc39.x86_64.rpm /home/fabiand/Downloads/libcurl-7.88.1-1.fc39.x86_64.rpm

did the trick to get a working curl and allow me to update (after a reboot).

Yes, mee too.
I was surprised to see that the first rpm-ostree upgrade has generated many errors and failed on the next day of a fresh F39 Kinoite installation.
However, the update showed up in Discover, in the Operating system section.
I tried applying it via GUI, it was successfully downloaded, but again failed in Discover.
Well, after several reboots (and minor command line installs), the update again showed up in Discover.
I tried to start it again just for a laugh, but it did download and install!
After subsequent reboot, it now shows as the “currently booted version” in Discover, while the previous is now the “Fallback one”.
Apart from that the system is very stable, and the CPU temperatures on the Linux 6.3 kernel are at their new lows, never seen in Windows, and better than in F37 Workstation.

P.s. I’ve opened Discover just to look up information to write this post, and it gave me this popup message:
rpm-ostree transaction failed with: error: While pulling fedora/rawhide/x86_64/kinoite: While fetching https://ostree.fedoraproject.org/summary.sig: [16] Error in the HTTP2 framing layer

Although I did not click anything, and have set updates to manual.