Not able to update Silverblue 31

When I try to update my Silverblue 31 instalation using rpm-ostree update I get following error: error: Unrecognized archive format. This is the whole output of the command:

sudo rpm-ostree update
1 metadata, 0 content objects fetched; 569 B transferred in 2 seconds
Checking out tree af7560f… done
Enabled rpm-md repositories: rawhide fedora-modular rpmfusion-free-updates updates-modular rpmfusion-free rpmfusion-free-rawhide updates-testing updates
Updating metadata for ‘rawhide’… done
rpm-md repo ‘rawhide’; generated: 2019-07-03T07:56:00Z
Updating metadata for ‘fedora-modular’… done
rpm-md repo ‘fedora-modular’; generated: 2019-07-03T07:51:26Z
Updating metadata for ‘rpmfusion-free-updates’… done
rpm-md repo ‘rpmfusion-free-updates’; generated: 2019-07-03T17:49:33Z
Updating metadata for ‘updates-modular’… done
rpm-md repo ‘updates-modular’; generated: 2019-07-03T07:51:26Z
Updating metadata for ‘rpmfusion-free’… done
rpm-md repo ‘rpmfusion-free’; generated: 2019-07-03T17:49:33Z
Updating metadata for ‘rpmfusion-free-rawhide’… done
rpm-md repo ‘rpmfusion-free-rawhide’; generated: 2019-07-03T17:49:33Z
Updating metadata for ‘updates-testing’… done
rpm-md repo ‘updates-testing’; generated: 2019-07-03T07:56:00Z
Updating metadata for ‘updates’… done
rpm-md repo ‘updates’; generated: 2019-07-03T07:56:00Z
Importing rpm-md… done
Resolving dependencies… done
Will download: 1 package (38,9 kB)
Downloading from ‘rawhide’… done
Importing packages… done
error: Unrecognized archive format

Same:

[tpmajer@silverblue ~] rpm-ostree update --preview 1 metadata, 0 content objects fetched; 569 B transferred in 3 seconds Enabled rpm-md repositories: rawhide google-chrome Updating metadata for 'rawhide'... done rpm-md repo 'rawhide'; generated: 2019-07-04T20:28:37Z Updating metadata for 'google-chrome'... done rpm-md repo 'google-chrome'; generated: 2019-06-27T19:03:51Z Importing rpm-md... done AvailableUpdate: Version: Rawhide.20190704.n.1 (2019-07-04T19:20:13Z) Commit: 4096266a81ed494c0f83cd66baed8850bee39e44315ae5258b9be7dacfedeb6f GPGSignature: 1 signature Signature made czw, 4 lip 2019, 21:20:22 using RSA key ID 50CB390B3C3359C4 Good signature from "Fedora <fedora-31-primary@fedoraproject.org>" Upgraded: NetworkManager 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-adsl 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-bluetooth 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-config-connectivity-fedora 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-libnm 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-ppp 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-wifi 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 NetworkManager-wwan 1:1.20.0-0.2.fc31 -> 1:1.20.0-0.3.fc31 fuse-common 3.6.1-1.fc31 -> 3.6.1-2.fc31 fuse3 3.6.1-1.fc31 -> 3.6.1-2.fc31 fuse3-libs 3.6.1-1.fc31 -> 3.6.1-2.fc31 guile22 2.2.4-3.fc30 -> 2.2.6-1.fc31 kernel 5.2.0-0.rc7.git0.1.fc31 -> 5.2.0-0.rc7.git1.1.fc31 kernel-core 5.2.0-0.rc7.git0.1.fc31 -> 5.2.0-0.rc7.git1.1.fc31 kernel-devel 5.2.0-0.rc7.git0.1.fc31 -> 5.2.0-0.rc7.git1.1.fc31 kernel-modules 5.2.0-0.rc7.git0.1.fc31 -> 5.2.0-0.rc7.git1.1.fc31 kernel-modules-extra 5.2.0-0.rc7.git0.1.fc31 -> 5.2.0-0.rc7.git1.1.fc31 libbytesize 2.0-1.fc31 -> 2.1-1.fc31 libdnf 0.31.0-5.fc31 -> 0.35.1-1.fc31 libdrm 2.4.98-1.fc31 -> 2.4.99-1.fc31 libmodulemd1 1.8.11-2.fc31 -> 1.8.13-1.fc31 libreport-filesystem 2.10.0-3.fc31 -> 2.10.1-1.fc31 libssh 0.9.0-1.fc31 -> 0.9.0-2.fc31 nss 3.44.0-2.fc31 -> 3.44.1-1.fc31 nss-softokn 3.44.0-2.fc31 -> 3.44.1-1.fc31 nss-softokn-freebl 3.44.0-2.fc31 -> 3.44.1-1.fc31 nss-sysinit 3.44.0-2.fc31 -> 3.44.1-1.fc31 nss-util 3.44.0-2.fc31 -> 3.44.1-1.fc31 openssh 8.0p1-5.fc31 -> 8.0p1-6.fc31 openssh-clients 8.0p1-5.fc31 -> 8.0p1-6.fc31 openssh-server 8.0p1-5.fc31 -> 8.0p1-6.fc31 pcre2 10.33-5.fc31 -> 10.33-6.fc31 pcre2-utf16 10.33-5.fc31 -> 10.33-6.fc31 perl-Carp 1.50-440.module_f31+4863+98a48781 -> 1.50-440.module_f31+4963+a5814580 perl-Data-Dumper 2.174-440.module_f31+4863+98a48781 -> 2.174-440.module_f31+4963+a5814580 perl-Encode 4:3.01-440.module_f31+4863+98a48781 -> 4:3.01-440.module_f31+4963+a5814580 perl-Errno 1.30-440.module_f31+4865+3ed6caa2 -> 1.30-440.module_f31+4963+a5814580 perl-Exporter 5.73-440.module_f31+4863+98a48781 -> 5.73-440.module_f31+4963+a5814580 perl-File-Path 2.16-440.module_f31+4863+98a48781 -> 2.16-440.module_f31+4963+a5814580 perl-File-Temp 1:0.230.900-440.module_f31+4863+98a48781 -> 1:0.230.900-440.module_f31+4963+a5814580 perl-Getopt-Long 1:2.50-440.module_f31+4863+98a48781 -> 1:2.50-440.module_f31+4963+a5814580 perl-HTTP-Tiny 0.076-440.module_f31+4863+98a48781 -> 0.076-440.module_f31+4963+a5814580 perl-IO 1.40-440.module_f31+4865+3ed6caa2 -> 1.40-440.module_f31+4963+a5814580 perl-MIME-Base64 3.15-440.module_f31+4863+98a48781 -> 3.15-440.module_f31+4963+a5814580 perl-PathTools 3.78-440.module_f31+4863+98a48781 -> 3.78-440.module_f31+4963+a5814580 perl-Pod-Escapes 1:1.07-440.module_f31+4863+98a48781 -> 1:1.07-440.module_f31+4963+a5814580 perl-Pod-Perldoc 3.28.01-440.module_f31+4863+98a48781 -> 3.28.01-440.module_f31+4963+a5814580 perl-Pod-Simple 1:3.39-1.fc31 -> 1:3.39-1.module_f31+4963+a5814580 perl-Pod-Usage 4:1.69-440.module_f31+4863+98a48781 -> 4:1.69-440.module_f31+4963+a5814580 perl-Scalar-List-Utils 3:1.50-440.module_f31+4863+98a48781 -> 3:1.50-440.module_f31+4963+a5814580 perl-Socket 4:2.029-3.module_f31+4865+3ed6caa2 -> 4:2.029-3.module_f31+4963+a5814580 perl-Storable 1:3.15-440.module_f31+4863+98a48781 -> 1:3.15-440.module_f31+4963+a5814580 perl-Term-ANSIColor 4.06-440.module_f31+4863+98a48781 -> 4.06-440.module_f31+4963+a5814580 perl-Term-Cap 1.17-440.module_f31+4863+98a48781 -> 1.17-440.module_f31+4963+a5814580 perl-Text-ParseWords 3.30-440.module_f31+4863+98a48781 -> 3.30-440.module_f31+4963+a5814580 perl-Text-Tabs+Wrap 2013.0523-440.module_f31+4863+98a48781 -> 2013.0523-440.module_f31+4963+a5814580 perl-Time-Local 2:1.280-440.module_f31+4863+98a48781 -> 2:1.280-440.module_f31+4963+a5814580 perl-Unicode-Normalize 1.26-440.module_f31+4863+98a48781 -> 1.26-440.module_f31+4963+a5814580 perl-constant 1.33-440.module_f31+4863+98a48781 -> 1.33-440.module_f31+4963+a5814580 perl-interpreter 4:5.30.0-440.module_f31+4865+3ed6caa2 -> 4:5.30.0-440.module_f31+4963+a5814580 perl-libs 4:5.30.0-440.module_f31+4865+3ed6caa2 -> 4:5.30.0-440.module_f31+4963+a5814580 perl-macros 4:5.30.0-440.module_f31+4865+3ed6caa2 -> 4:5.30.0-440.module_f31+4963+a5814580 perl-parent 1:0.237-440.module_f31+4863+98a48781 -> 1:0.237-440.module_f31+4963+a5814580 perl-podlators 1:4.12-1.module_f31+4865+3ed6caa2 -> 1:4.12-1.module_f31+4963+a5814580 perl-threads 1:2.22-440.module_f31+4863+98a48781 -> 1:2.22-440.module_f31+4963+a5814580 perl-threads-shared 1.60-440.module_f31+4863+98a48781 -> 1.60-440.module_f31+4963+a5814580 pulseaudio 12.2-6.fc31 -> 12.2-7.fc31 pulseaudio-libs 12.2-6.fc31 -> 12.2-7.fc31 pulseaudio-libs-glib2 12.2-6.fc31 -> 12.2-7.fc31 pulseaudio-module-bluetooth 12.2-6.fc31 -> 12.2-7.fc31 pulseaudio-module-x11 12.2-6.fc31 -> 12.2-7.fc31 pulseaudio-utils 12.2-6.fc31 -> 12.2-7.fc31 [tpmajer@silverblue ~] rpm-ostree update
error: Bus owner changed, aborting.
[tpmajer@silverblue ~] rpm-ostree update error: Bus owner changed, aborting. [tpmajer@silverblue ~] rpm-ostree update
error: Bus owner changed, aborting.
[tpmajer@silverblue ~] rpm-ostree update error: Bus owner changed, aborting. [tpmajer@silverblue ~] rpm-ostree update
error: Bus owner changed, aborting.
[tpmajer@silverblue ~] rpm-ostree update error: Bus owner changed, aborting. [tpmajer@silverblue ~] rpm-ostree update
⠒ Scanning metadata: 1…
Scanning metadata: 1… done
Checking out tree 4096266… done
Enabled rpm-md repositories: rawhide google-chrome
Updating metadata for ‘rawhide’… done
rpm-md repo ‘rawhide’; generated: 2019-07-04T20:28:37Z
Updating metadata for ‘google-chrome’… done
rpm-md repo ‘google-chrome’; generated: 2019-06-27T19:03:51Z
Importing rpm-md… done
Resolving dependencies… done
Will download: 1 package (6,9 MB)
Downloading from ‘rawhide’… done
Importing packages… done
error: Unrecognized archive format
[tpmajer@silverblue ~]$ rpm-ostree update
error: Bus owner changed, aborting.

Silverblue Rawhide

Unfortunately, It’ s not able to install any package:

sudo rpm-ostree install gtk3-devel glib2-devel
[sudo] senha para thiago: 
Checking out tree 4096266... done
Enabled rpm-md repositories: rawhide fedora-modular rpmfusion-free-updates updates-modular rpmfusion-free rpmfusion-free-rawhide updates-testing updates
rpm-md repo 'rawhide' (cached); generated: 2019-07-04T20:28:37Z
rpm-md repo 'fedora-modular' (cached); generated: 2019-07-04T20:23:29Z
rpm-md repo 'rpmfusion-free-updates' (cached); generated: 2019-07-04T12:20:08Z
rpm-md repo 'updates-modular' (cached); generated: 2019-07-04T20:23:29Z
rpm-md repo 'rpmfusion-free' (cached); generated: 2019-07-04T12:20:08Z
rpm-md repo 'rpmfusion-free-rawhide' (cached); generated: 2019-07-04T12:20:08Z
rpm-md repo 'updates-testing' (cached); generated: 2019-07-04T20:28:37Z
rpm-md repo 'updates' (cached); generated: 2019-07-04T20:28:37Z
Importing rpm-md... done
Resolving dependencies... done
Will download: 62 packages (15,9 MB)
Downloading from 'fedora-modular'... done
Downloading from 'rawhide'... done
Importing packages... done
error: Unrecognized archive format

This is the output of journalctl:

journalctl -b -t 'rpm-ostree'
-- Logs begin at Mon 2019-06-10 20:57:18 -03, end at Sat 2019-07-06 13:21:32 -03. --
jul 06 12:06:02 localhost.localdomain rpm-ostree[2360]: Reading config file '/etc/rpm-ostreed.conf'
jul 06 12:06:05 localhost.localdomain rpm-ostree[2360]: In idle state; will auto-exit in 61 seconds
jul 06 12:06:05 localhost.localdomain rpm-ostree[2360]: Allowing active client :1.554 (uid 1000)
jul 06 12:06:05 localhost.localdomain rpm-ostree[2360]: client(id:gnome-software dbus:1.554 unit:session-2.scope uid:1000) added; new total=1
jul 06 12:06:12 localhost.localdomain rpm-ostree[2360]: Initiated txn RefreshMd for client(id:gnome-software dbus:1.554 unit:session-2.scope uid:1000): /org/projectatomic/rpmostree1/fedora_workstation
jul 06 12:06:26 localhost.localdomain rpm-ostree[2360]: Txn RefreshMd on /org/projectatomic/rpmostree1/fedora_workstation successful
jul 06 13:14:11 localhost.localdomain rpm-ostree[2360]: client(id:cli dbus:1.694 unit:dbus-:1.2-com.gexperts.Tilix@0.service uid:0) added; new total=2
jul 06 13:14:12 localhost.localdomain rpm-ostree[2360]: Initiated txn PkgChange for client(id:cli dbus:1.694 unit:dbus-:1.2-com.gexperts.Tilix@0.service uid:0): /org/projectatomic/rpmostree1/fedora_workstation
jul 06 13:15:46 localhost.localdomain rpm-ostree[2360]: Preparing pkg txn; enabled repos: ['rawhide', 'fedora-modular', 'rpmfusion-free-updates', 'updates-modular', 'rpmfusion-free', 'rpmfusion-free-rawhide', 'updates-testing', 'updates'] solvables: 1839>
jul 06 13:15:53 localhost.localdomain rpm-ostree[2360]: Txn PkgChange on /org/projectatomic/rpmostree1/fedora_workstation failed: Unrecognized archive format
jul 06 13:15:53 localhost.localdomain rpm-ostree[2360]: client(id:cli dbus:1.694 unit:dbus-:1.2-com.gexperts.Tilix@0.service uid:0) vanished; remaining=1

I don’t … maybe there are some corrupted packages in Fedora repo. I was able to install gcc, g++, gnome-tweak-tools, vim and tilix. But I was not able to install fish, clang and neovim.

One package with this problem is libuv. It’ s possible to download it from http://download-ib01.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/l/libuv-1.30.1-1.fc31.x86_64.rpm . I was able to extract the content of this package using rpm2cpio. It seems to be correct. But there is something wrong with this file, I just don’ t know how to check it.

I don’t know what the issue was, but rebasing to 30 and then back to rawhide got it unstuck for me.

@tpb, some packages from Fedora 31 are archived using ZSTD compression format. Unfortunately, today rpm-ostree is not able to deal with this format. But there is already a pull request waiting for being accepted into rpm-ostree. See https://github.com/projectatomic/rpm-ostree/pull/1866

Ah. I must have gotten lucky that the first update after rebasing had no issues.

We’ll get an update into f30 ASAP to fix this, https://koji.fedoraproject.org/koji/taskinfo?taskID=36210834 is building now. (Although ironically it may be zstd compressed, going to check at the end; regardless will update this post (and the github issue) with workaround instructions once we have them.

Wait no, this doesn’t seem to affect f30. If someone is really hitting it on f30, please post exactly which package you had and which rpm-md repos you had enabled. (For example, if you had the rawhide repo enabled on f30, that would cause this but that’s clearly not a default)

Here is the output from my f30 system, looks like rpmfusion is the non-standard part. I’m not sure why it reports rawhide, when layeredpackages shows I got the version for fedora30 installed. Going to try to remove it and see if I still hit problems:

edwin@linux:~ % sudo rpm-ostree status
State: idle
AutomaticUpdates: stage; rpm-ostreed-automatic.timer: no runs since boot
Deployments:
● ostree://fedora-workstation:fedora/30/x86_64/silverblue
Version: 30.20190704.0 (2019-07-04T01:47:22Z)
BaseCommit: 846d4b84b57ab1f354fd346aa586af1f1785b277d0bba23930a94ddcdafdf3cb
GPGSignature: Valid signature by F1D8EC98F241AAF20DF69420EF3C111FCFC659B9
LayeredPackages: chromium compat-ffmpeg28 evolution ffmpeg-libs firefox-wayland gnome-tweak-tool
mozilla-ublock-origin neovim pass powertop stow tig tmux zsh
LocalPackages: rpmfusion-free-release-30-0.2.noarch

ostree://fedora-workstation:fedora/30/x86_64/silverblue
Version: 30.20190617.0 (2019-06-17T18:05:37Z)
BaseCommit: 209dfbef8f40b50022b178be3915d2df401780dee7d044361332d89a4bf9cce9
GPGSignature: Valid signature by F1D8EC98F241AAF20DF69420EF3C111FCFC659B9
LayeredPackages: chromium compat-ffmpeg28 evolution ffmpeg-libs firefox-wayland gnome-tweak-tool
mozilla-ublock-origin neovim pass powertop stow tig tmux zsh
LocalPackages: rpmfusion-free-release-30-0.2.noarch

sudo rpm-ostree upgrade
note: automatic updates (stage) are enabled
1 metadata, 0 content objects fetched; 569 B transferred in 2 seconds
Checking out tree 308bfda… done
Enabled rpm-md repositories: fedora updates rpmfusion-free-rawhide
rpm-md repo ‘fedora’ (cached); generated: 2019-04-25T23:49:41Z
rpm-md repo ‘updates’ (cached); generated: 2019-07-12T00:49:59Z
rpm-md repo ‘rpmfusion-free-rawhide’ (cached); generated: 2019-07-10T14:29:09Z
Importing rpm-md… done
Resolving dependencies… done
Will download: 2 packages (7.5 MB)
Downloading from ‘updates’… done
Downloading from ‘rpmfusion-free-rawhide’… done
Importing packages… done
error: Unrecognized archive format

Looks like removing/readding the rpmfusion repos fixed it for Fedora30:

sudo rpm-ostree uninstall rpmfusion-free-release
systemctl reboot
sudo rpm-ostree uninstall compat-ffmpeg28 ffmpeg-libs
sudo rpm-ostree upgrade
sudo rpm-ostree install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
systemctl reboot
sudo rpm-ostree install compat-ffmpeg28 ffmpeg-libs

Apparently rpmfusion-free-release-30-0.2.noarch was pointing to rawhide, rpmfusion-free-release-30-1.noarch points to the right place (this might be due to me installing Fedora 30 while it was still in pre-release state, and the repo configuration not auto-updating itself).

Sorry for the red-herring, you were right, I had mistakenly configured my Fedora30 system to use a rawhide repo without even realizing until now.

I’m having this problem when updating in rawhide (f31):

sudo rpm-ostree update
[sudo] senha para thiago:
1 metadata, 0 content objects fetched; 569 B transferred in 3 seconds
Checking out tree 053e8a9… done
Enabled rpm-md repositories: rawhide fedora-modular updates-modular updates-testing updates
rpm-md repo ‘rawhide’ (cached); generated: 2019-07-12T02:33:03Z
rpm-md repo ‘fedora-modular’ (cached); generated: 2019-07-09T17:59:48Z
rpm-md repo ‘updates-modular’ (cached); generated: 2019-07-12T02:27:34Z
rpm-md repo ‘updates-testing’ (cached); generated: 2019-07-12T02:33:03Z
rpm-md repo ‘updates’ (cached); generated: 2019-07-12T02:33:03Z
Importing rpm-md… done
Resolving dependencies… done
Will download: 1 package (6,7 MB)
Downloading from ‘rawhide’… done
Importing packages… done
error: Unrecognized archive format

Fixing rawhide should be done now with: https://koji.fedoraproject.org/koji/buildinfo?buildID=1312669

Now of course…those packages are zstd compressed…so, you have two choices; the first of which is to uninstall all layered packages, wait till the next treecompose (should be…daily?) and then upgrade, then reinstall your layered packages.

Alternatively, using the f30 version should work:

$ rpm-ostree override replace https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc30/x86_64/rpm-ostree-{libs-,}2019.4.28.g44395673-3.fc30.x86_64.rpm

Hi @walters, unfortunately the package are using zstd (I replace f30 with f31):

sudo rpm-ostree override replace https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc31/x86_64/rpm-ostree-{libs-,}2019.4.28.g44395673-3.fc31.x86_64.rpm
Downloading 'https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc31/x86_64/rpm-ostree-libs-2019.4.28.g44395673-3.fc31.x86_64.rpm'... done!
Downloading 'https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc31/x86_64/rpm-ostree-2019.4.28.g44395673-3.fc31.x86_64.rpm'... done!
error: Unrecognized archive format 

Maybe I’ll have to wait next treecompose and uninstall all layered packages.

I have the same problem.

I’ve reinstalled the packages after “rpm-ostree reset”.

sudo rpm-ostree reset
sudo rpm-ostree install \
https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-rawhide.noarch.rpm \
https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-rawhide.noarch.rpm
sudo rpm-ostree install <RPMS>

I have not found any problems with the Fedora silverblue rawhide package update.

But
In my case, the same problem when installing the kmod-nvidia package.

rpm-ostree install kmod-nvidia
...
error: Unrecognized archive format

After “rpm-ostree reset”, I was able to solve the problem.

I’m sorry I did not have good English.

~ » rpm-ostree override replace https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc30/x86_64/rpm-ostree-2019.4.28.g44395673-3.fc30.x86_64.rpm https://kojipkgs.fedo
raproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc30/x86_64/rpm-ostree-libs-2019.4.28.g44395673-3.fc30.x86_64.rpm
Downloading 'https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc30/x86_64/rpm-ostree-2019.4.28.g44395673-3.fc30.x86_64.rpm'... done!
Downloading 'https://kojipkgs.fedoraproject.org//packages/rpm-ostree/2019.4.28.g44395673/3.fc30/x86_64/rpm-ostree-libs-2019.4.28.g44395673-3.fc30.x86_64.rpm'... done!
Checking out tree eca1473... done
Enabled rpm-md repositories: keybase flatcap-neomutt rawhide google-chrome-beta
Updating metadata for 'keybase'... done
rpm-md repo 'keybase'; generated: 2019-07-10T18:38:48Z
rpm-md repo 'flatcap-neomutt' (cached); generated: 2019-07-16T07:54:55Z
rpm-md repo 'rawhide' (cached); generated: 2019-07-15T20:48:27Z
rpm-md repo 'google-chrome-beta' (cached); generated: 2019-07-15T20:55:49Z
Importing rpm-md... done
Resolving dependencies... done
error: Could not depsolve transaction; 3 problems detected:
 Problem 1: conflicting requests
  - nothing provides librpm.so.8()(64bit) needed by rpm-ostree-libs-2019.4.28.g44395673-3.fc30.x86_64
  - nothing provides librpmio.so.8()(64bit) needed by rpm-ostree-libs-2019.4.28.g44395673-3.fc30.x86_64
 Problem 2: conflicting requests
  - nothing provides librpm.so.8()(64bit) needed by rpm-ostree-2019.4.28.g44395673-3.fc30.x86_64
  - nothing provides librpmio.so.8()(64bit) needed by rpm-ostree-2019.4.28.g44395673-3.fc30.x86_64

so I guess the only option is to rebase to f30 and then back to rawhide :frowning:

1 Like

@milos, just do rpm-ostree update. The update will install the fix to this problem.

Any chance to have https://github.com/projectatomic/rpm-ostree/pull/1866 packed to Silverblue 30? I am not able to upgrade from 30 to rawhide because of this.