[Solved] Rawhide / F35 unable to upgrade

Current status of my installation:

$ rpm-ostree status -b
State: idle
BootedDeployment:
ā— ostree://fedora:fedora/rawhide/x86_64/silverblue
                   Version: Rawhide.20210208.n.0 (2021-02-08T06:07:03Z)
                BaseCommit: 54615533ea9cde210a04139d6d4089928cdf5818790a1ed66b88f001afe05561
              GPGSignature: Valid signature by 963A2BEB02009608FE67EA4249FD77499570FF31
           LayeredPackages: google-noto-serif-cjk-sc-fonts screenfetch tlp

I tried to perform a upgrade on 11, Feb 10:00 UTC+8 and 22:00 UTC+8, and got the following error:

$ rpm-ostree upgrade
ā ’ Receiving metadata objects: 0/(estimating) -/s 0 å­—čŠ‚... 
Receiving metadata objects: 0/(estimating) -/s 0 å­—čŠ‚... done
Checking out tree 9355ebb... done
Enabled rpm-md repositories: fedora-cisco-openh264 rawhide
Updating metadata for 'fedora-cisco-openh264'... done
error: Updating rpm-md repo 'fedora-cisco-openh264': Failed to download gpg key for repo 'fedora-cisco-openh264': Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-35-x86_64 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-35-x86_64]

UPD: Solution

Tried this under the /etc/pki/rpm-gpg/ folder:

# ln -s RPM-GPG-KEY-fedora-35-primary RPM-GPG-KEY-fedora-35-x86_64

As $releasever becomes 35, edit /etc/yum.repos.d/fedora-cisco-openh264.repo, from

metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-$releasever&arch=$basearch

to

metalink=https://mirrors.fedoraproject.org/metalink?repo=fedora-cisco-openh264-rawhide&arch=$basearch

to prevent a 404 error (The above one is the default config for me after I rebase my silverblue from F33 to silverblue, it works before F34 was branched, but now I can only get a 404 error :rofl: ).

2 Likes