Cannot Screen Share with Chromium

Friends, Fedorans, Distrowomen,

I have to MS Teams for my work and I use the web version of it in Chromium. Everything in it works fine with the exception of being able to share my screen. Here’s what I have:

  • Fedora 37
  • KDE Plasma
  • Chromium 111 installed via RPM
  • Opera 96 installed via RPM

From what I’ve read, it’s screen sharing in general on Chromium and not just Teams. Here’s what I’ve tried so far:

  1. Logged out of Plasma (Using X) and logged back in (Using Wayland). Teams says it’s sharing my screen but my colleagues don’t see it.
  2. I tried screen sharing in Opera and it worked fine
  3. Checked the permissions in Chromium but there isn’t any option for “Screen Sharing”
  4. I checked chrome://flags/#enable-webrtc-pipewire-capturer and it didn’t help either
  5. I’m about to try installing the Flatpack version and see if it makes any difference.

I was using the “Teams Insider” build from the MS repo, but MS stopped supporting it and now recommend using the PWA version instead. I’m fine with that because sometimes when Teams would launch, it would randomly reset my display manager.

I’m sure someone else has run into this issue and I’m wondering how you were able to fix it.

I have fedora kinoite 37 on Wayland. I use teams in the ms edge flatpak and can share my screen or a window

I can test chromium in the next few days.

I haven’t experimented alot with this but last time I tried, i could share a window but not the entire screen. When I share entire screen my meeting participants only see a black screen.

I’m running gnome on wayland, f37.

There seems to be a bridge in the works that might help.

By chance are you using the flatpak? I’ve had better luck with the flatpak over RPM with screen sharing on Wayland for a few 3rd party apps (Zoom, Slack).

I’m not against installing Edge to use for all my Office 365 stuff which is what I’ve been doing with Chromium.

No. In my original post I wrote that I have it installed via RPM. I removed it and installed the Flatpack version and there wasn’t any change.

1 Like

Kinoite user here, using Wayland + proprietary NVIDIA drivers:

  1. Sharing screens or windows doesn’t work for me
  2. Sharing single-tabs does work
  3. I haven’t checked with Chromium; the closest thing is the Brave browser
  4. I’m using the Flatpak version

Try adding these flags to the command that launches your Chromium browser:
--enable-features=UseOzonePlatform,WebRTCPipeWireCapturer --ozone-platform=wayland

Microsoft seems getting nervous about security … install Microsoft Edge to use Microsoft Teams. Chromium is a good browser being research base financed by Google, Microsoft and other … don’t mix up connected apps, use different devices (just an opinion).

What exactly does this have to do with the topic of screen sharing?

Screen sharing can be a security issue as Microsoft Teams goes with Azure Active Directory, Azure Graph in secured environment across large corporate user base. Security is also a concern for Red Hat so …

One of the whole selling points of Teams, along with all these other communication apps, is being able to share your screen since so many people work remote now. Microsoft blocking screen sharing “because security” makes no sense because that’s a decision for the customer to make.

I used Windows Pro moving to Linux that I like and know for years as devices are not eligible for W11. Now with Fedora 38 and Microsoft Edge, no access to OneDrive that I use with a free account. The content has been moved to Google before, nothing is lost as I use several devices with Ubuntu, CentOS and Chrome or Chromium … I like the idea of Azure cognitive services, Office 365, T-SQL, Graph, Active Directory, Teams allowing large scale Scrum framework that I know about, similar features exist with Red Hat and IBM Cloud.
What I’m saying is just that Microsoft is closing the door to Linux as options to access OneDrive are limited to Apple or Android … Android is mobile device with full blow of Microsoft apps …

OneDrive works just fine from a browser. Sure I have to copy stuff to it manually, but this is all for my job so switching to another service like Google isn’t an option, because my company uses Office 365. As for my initial question about troubleshooting “why can’t I screen share in Fedora”, do you have any suggestions that would help?

I do not know if this helps, but sounds promising to me:


I am on Arch Linux and since August every version, currently Chromium 96.0.4664.110 Arch Linux, but you need the xdg-desktop-portal running


Jan 4, 2022 at 15:45

Using Teams in Chromium(flathub flatpak) today I successfully was able to share my screen (monitor), a window (app), and a Chromium browser tab.

During this session I was also able to talk to the other participant.

Fedora Kinoite 37, wayland

It’s come back today … something happened, maybe just what I say on this blog …

Out of curiosity, @alys did you find a solution?

I tried the Edge Flatpack and that seems to be working.

1 Like

Hi Alys,
Same here.
F38 / xfce4 spin.
Only edge (rpm installed) worked.