Cannot share screen properly on Microsoft Teams

I have Fedora 34 Workstation and I cannot properly share screen on Microsoft Teams with Google Chrome.

If I share the entire screen, both me in the preview and the other participants after I share see it fully black, they only see a black box that fill all the screen.

If I share a single windows it works now and then. But, in this case, if I stop sharing and then re-share another window, participant still see the old window, even if I closed the application that generated that window in the meantime. To change window I have to exit the meeting and re-enter.

Plus I cannot share the window of some applications like Master PDF Editor.


Have you checked an other browser? Same result?

With Firefox Microsoft Teams does not work at all.

So I’m not sure what other browser I should check.

I have Brave but didn’t check with it. I assume the results would be the same.

Did you see this?

I can certainly install the proprietary app, but due to security concerns over proprietary apps I would prefer the web application to work

1 Like

Moreover, it used to work before I updated my system, so I think it is a regression.

Does anyone else have this same problem?

I am facing same issue. I can share screen from Edge Browser but they see just black screen with cursor.

I have teams app as well and I can’t share screen from there at all. I don’t see anything in share tray to select.

Might be that Microsoft now more about it. Have you had a look there ?

Facing the same issue even on the proprietary app. Clicking the share button, the list to choose Desktop to share is blank, This used to work correctly last week… :frowning:
Not sure which updates were installed (teams or OS upgrades)

  • On fedora 34 with wayland.
1 Like

There was a Kernel update from 5.11 to 5.12 on the weekend. You might try an older Kernel version. But i guess this issue has todo with your Graphic card. Changes the Kernel it messes up the driver.

I’m having the same issues i tried switching to xorg just as a test and still no screen sharing…

Still I cannot share the full screen with Microsoft Teams web app.

Sharing a single windows work.

Anyone now more about this?

1 Like

Sharing in Wayland doesn’t work. It works fine in Xorg


UPDATE: I uninstalled teams and deleted all corresponding directories switched to Xorg and reinstalled the latest version of teams, all system updates and everything is working!


The same issue here

Do you use Xorg? Does the previous post can help?

Same here if use gnome with wayland, but I use Gnome with X11 and it all features Microsofit Teams is works fine. but there is drawback wihen using gnome with Xorg, my 3 touch finger can’t work any more.

I tried to use Xorg, but so just like Afiadi Soenarto says, on touchpad my 3 touch finger can’t work any more, and this is one of the bests features that i really use… :frowning:

Sharing in MS Teams in both Chrome/Chromium and Microsoft Edge works under Wayland if you enable the webrtc-pipewire flag:


Thank you for the tip! I’ll try and report afther that.