F35 Wayland: Sharing entire screen in Chrome apps like zoom, teams not possible


I just tried out Fedora silverblue 35 and wayland. In wayland, the native versions of apps like Zoom or slack aren"t working. But that’s no problem, because there exists Chrome extensions for Zoom etc… The only downside is, that when I start Zoom or Teams in Chrome I am able to share one app only. I’m unable to share the entire screen. I’m able to select to share the entire screen, but it’s black.

So I just wanted to ask if that’s to be expected or if there exists a workaround (like setting a different security settings)?

As solution I found that I should switch to Xorg. But that’s no option, because Xorg causes other problems on my hardware (lenovo thinkpad p15 gen 1+ 5k monitor + dedicated nvidia quadro 4000 graphics card). Had problems that with xorg my 5k monitor is not handled correctly for instance. So I would like to stay with wayland.

So does anybody know if it is fixable or by design?

Best regards

Try this version of Chromium and see if it fixes the issue:

flatpak install --user https://dl.flathub.org/build-repo/75793/org.chromium.Chromium.flatpakref
1 Like

Oh thanks. Couldn’t try it because the build seems to have been removed:

> flatpak install --user https://dl.flathub.org/build-repo/75793/org.chromium.Chromium.flatpakref
Fehler: Can't load uri https://dl.flathub.org/build-repo/75793/org.chromium.Chromium.flatpakref: Server returned status 404: Not Found

I noticed that not all of my applications are selectable in the share screen. So this is a no go issue for me because I need to be able to share all application. So I will switch back to windows and try it again if the issue you mentioned is merged / fixed.


Maybe I’ll give these Wayland option in google chrome flags another try: Using Google Chrome/Chromium with native Wayland backend in Arch Linux | import pyChao

Already played with one of these flags, but don’t remember if it was this “WebRTC PipeWire support” mentioned in the thread above.

At least it sounds as if it should be possible to get it done.

Best regards

I can’t say something specific about flatpak and/or Silverblue, but I can confirm it works under wayland when

  • Chrome has the h264 codec enabled (in my case this wasn’t the case when installing chromium, but chromium-freeworld from RPM fusion free)
  • in chrome you have the experimental flag WebRTC PipeWire support enabled

Note that Pipewire or Wayland (?) shows you a confirmation dialog when sharing from a web application. In my case I have to approve twice, but it works finally


Jay it’s working. Activated both wayland flags in Chrome :-).

1 Like

Ah sorry.

I was so biased that I thought you were using NVIDIA proprietary drivers.

Yes I use the proprietary drivers because I had problems with the nouveau one months ago:

rpm -qa | grep nvidia

But it / Wayland works with the proprietary driver :slight_smile:

But are you able to share the screen at all using Wayland AND NVIDIA proprietary drivers, without using the version of Chromium I linked you?

What version of Chromium are you using?

I use the lastest version of Chrome (98.0.4758.102). Screen sharing via the Zoom / Teams worked perfectly today. Used the web version of both :slight_smile:

I see.

Can you post the result of:



lspci -nnk | grep -iA2 vga


I can confirm: Wayland screen sharing was broken for quite a while on Nvidias **** driver but with the 5 sth driver it started to work again! And the commands print out exactly what they should :wink:

Everything is fine now. Can’t post the results of the commands above, because due to another docker Issue (https://discussion.fedoraproject.org/t/slow-rootless-docker-performance/73739) I just did a clean install - and I haven’t configured the dedicated nvidia driver yet.


That double permissions thing has become a real annoyance.

Yeah I too was able to share the screen in Microsoft Teams web version with Chromium free-word Version 98.0.4758.102 (Official Build) (64-bit), Wayland and NVIDIA proprietary drivers 510.47.03

That double permissions thing has become a real annoyance.

They should be on it