Authentication is required to mount WDC hard drive, Fedora 36?


I have an internal drive from WDC in my computer that I store archives on. It is not the SSD drive I run my Fedora installation on. Whenever I try to access the drive after booting up my computer, I receive a prompt “Authentication is required to mount WDC”. Is this normal? Back in Ubuntu Gnome that I used, the files would just allow access to the disks with no options of mounting / dismounting inside Nautilus. I did disable fastboot coming from Windows 10. My question is whether I’ve done something incorrectly in the installation process, or if this is normal behavior in Fedora. If this is normal, how should I configure so that I don’t need to authenticate every time?

Looking for help. Thanks in advance.

If it is an internal drive, you should create an entry in /etc/fstab for it so it is mounted at boot.

If you need help with that please share the output of lsblk -o name,type,fstype,label,size,mountpoint,uuid


yes it is normal. Ubuntu has configuration to mount external drives without root access. fedora does not.

1 Like

Hey! Thanks and I really would appreciate with further help in configuring the values for the script. Attached is the screenshot. I cropped to focus on sdb disk which is the disk in question.

Glad to help, but you need to share the output via copy/paste, not a screenshot. I don’t want to rekey that UUID incorrectly.

1 Like

Understandable. Here it is.

sdb disk 931.5G
part ntfs Hard Drive
931.5G A82A3F672A3F3224
sr0 rom 1024M
disk 8G [SWAP]

Try this:

UUID=A82A3F672A3F3224          /path/to/mountpoint            ntfs3            users,nofail,dmask=0007,fmask=0117    0 0

Replace /path/to/mountpoint with the location you want to mount it. i.e. /mnt/wdc or something. Make sure you create the mountpoint first with mkdir

If you don’t have rights to the files, you may need to add the uid= and gid= mount options.


Could I just mount it to this address? /run/media/hugoye/Hard Drive. Do I have to create a mountpoint as such?

I would recommend against creating a permanent mountpoint inside /run. It would probably work but it doesn’t make much sense.

I see. So to set it for /mnt/wdc, all I have to do is mkdir /mnt/wdc?

Yes. Although you will probably need sudo.

1 Like

That was completed fine. It appears now that the hard drive does not show up in Nautilus in “Other locations” and the folder in mnt/wdc shows every file locked from accessing.

Can I see ls -l /mnt/wdc


OK, can we see the output of the command id

uid=1000(hugoye) gid=1000(hugoye) groups=1000(hugoye),10(wheel) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

I found that you can edit the fstab entry directly through Disks. This entry successfully lets me use the drive, but the only option with deleting files is “Delete permantently”. Would it also be possible to adjust it to implement the trash bin?

Try this in /etc/fstab

UUID=A82A3F672A3F3224          /mnt/wdc            ntfs3            users,nofail,dmask=0007,fmask=0117,uid=1000,gid=1000    0 0

That worked like a charm. Even the recycle bin option seems to have clicked together. I also added the entry for it to appear in user interface. Thank you very much.