Hard drive not automatically mounting

I’m running Fedora 33 on a laptop with the operating system on a SSD and data on a hard drive. Whenever I reboot the computer to install updates etc I have to manually mount the hard drive and unlock the printers in “settings”. How can I make these things happen automatically as is the case with manjaro?

I’m gonna suggest you some links but be warned, they involve modification of /etc/fstab which is a pretty sensitive file owing to the fact that it tells where your OS partitions are located as well.

  1. This one is the difficult way of doing so which I would ask you to avoid until you’re very sure of what you are doing. Ignore the disk formatting parts if you don’t need them and jump straight to the part where they are modifying the /etc/fstab file. fstab - How to mount a new drive on startup - Ask Ubuntu.

  2. If you are using Workstation (which I think you should for F34 would include GNOME 40 :partying_face:), you can use the following easier method which involves a GUI and is a lot safer from the previous one. automount - How to make partitions mount at startup? - Ask Ubuntu.

[But t0xic0der, these links are from Ubuntu forums! I want to make things work on Fedora. - Ah don’t worry! These would work just fine but if you aren’t careful enough, you might render your OS unbootable so discretion is advised.]

1 Like

Thanks, looks like I’m waiting for F34 before I tackle this.

Can encrypted volumes be automatically mounted by modifying the settings in Gnome disks? There’s no no password prompt after logging in whatsoever:

Please open your own thread for your issue. This thread has been closed for almost 1 1/2 years and applies to fedora 33.

Your own thread may get more and better responses