Upgraded to Fedora 39, can't mount any drive

I upgraded my backup PC today to Fedora 39. I use Fedora since 25 and no issues ever. But now all my attached drives are unmountable. Fstab is correct.

Only the bootdrive with Fedora works and I can mount the Windows drive I have on this machine. All other disks don’t mount and if I try to mount them it says:

“Failed to mount drivename”
Error mounting system-managed device /dev/sdb1: Operation not permitted.

What can I do now? I’m lost at the moment.

We will need to find information for the your disks.

What is the output of lsblk -f?

Do you have any errors in dmesg about the disks that fail to mount?

1 Like

The good news here is that “operation not permitted” probably means some configuration thing we can easily help you fix. Running into a situation where you might lose data is scary, but I think we’ve got good chances here.

A few more questions will help us help you.

Can you tell us more about the attached drives? How many are there, and how are they attached? Are you doing the same thing you did before to mount them (and what is that, exactly)?

You mention that the fstab is correct. Can you paste that here? (A tip: put the file between pairs of ``` on lines by themselves to format it nicely.)

I put a # in front of all added lines in fstab So only the basics are there. Then I can, after a restart, mount the drives by hand and everything works fine.

I don’t get it that after the upgrade it stopped working. I will try to reconfigure my fstab tomorrow.

One line I have (one disk) as example:

# SSD Rommeldisk / Sandisk 480Gb / sda
UUID=3BC75ECC3062973D /run/media/marc/Rommeldisk/ ntfs auto,users,nofail,uid=1000,gid=10$

And the Windows drive (that will mount with fstab) I got:

UUID=300444F80444C318 /run/media/marc/Windows11/ ntfs auto nosuid,nodev,nofail,x-gvfs-show
$ lsblk -f
NAME FSTYPE FSVER LABEL      UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sda                                                                              
└─sda1
     ntfs         Rommeldisk 3BC75ECC3062973D                      446.4G     0% /run/media/marc/Rommeldisk   

I know that /run/$USER exists after I login in, but I suspect that it will not exist when the machine boots and processes the mounts from /etc/fstab.

If you are going to mount from /etc/fstab you could use mount points that you create permanently in the file system. Maybe /home/$USER/mnt/Windows11 etc?

Windows is not the issue, that disk automounts with fstab. It’s with all the storage drives (6).

I don’t understand that fstab worked for years and now suddenly not after the upgrade. Apparently I missed something or did something stupid. :sweat_smile: Or something need to change in fstab for Fedora 39.

I FTFM.

PS:
I changed

ntfs auto,users,nofail,uid=1000,gid=10$

in

ntfs auto,nosuid,nodev,nofail,x-gvfs-show

and now it works again. I don’t get it, but I’m no specialist so I just followed manuals. Someone in another topic mentioned gnome disks (I use XFCE) and it’s installed. I just copied the settings it suggested ;).

Maybe someone can explain me what the different lines means? Would be appreciated.

As said above, you really shouldn’t have fstab entries using /run/media. That is reserved for use by udisks for automounting.

systemd mounts local filesystems very early in boot (local-fs.target). At that point, /run/media doesn’t exist yet, much less /run/media/marc/Rommeldisk. Because the mountpoint doesn’t exist, the mount will fail at boot. I suspect that gvfs/udisks is mounting it later once you’ve started your session.

Without x-gvfs-show, I’d guess that gvfs ignores the mount entirely, so if it failed to mount at boot, it’s not going to be mounted unless you do it manually with mount.

systemctl status /run/media/marc/Rommeldisk should show some of this.

Another potential sticking point is how the devices are mounted in fstab.
If you have removable devices (usb and similar) then they may not always get the same name with the system configures them. For example what may have been sdb last boot may become sdc the next boot. Mounting them using the device name may not always be the same every time.

For several years it has been recommended to mount devices using UUID or file system labels to avoid ambiguity during configuration.

As already mentioned the devices you choose to mount from /etc/fstab really should not be mounted at /run/media/marc/… because of potential timing conflicts in creation of the virtual file system (/run) vs the timing of when devices entered in fstab are mounted.

Thank you both for the input. I get it. I need some reading to do ;).
And I shall change my fstab. I’ll post probably my solution when I’v got it. Maybe handy for some other readers.

1 Like