Second HDD drive asks me permissions every time I boot up


I know this is a topic already explored, as I have followed this guide, but I couldn’t find a polkit-default-privs.local on my /etc folder. So then the other easy option was this guide which said to add an entry to /etc/fstab.

I went forward with the last guide, and now I rebooted and get this error:

An error occurred while accessing ‘Volume’, the system responded: The requested operation has failed: Error mounting system-managed device /dev/sdb1: wrong fs type, bad option, bad superblock on /dev/sdb1, missing codepage or helper program, or other error

What I did, was exactly as mentioned in the guide:

  • Create a folder with sudo mkdir /mnt/wdc
  • Add the entry to etc/fstab

Here is the CMD output:

[alessio-pc@fedora ~]$ sudo mkdir /mnt/wdc
[sudo] password for alessio-pc: 
[alessio-pc@fedora ~]$ ls -l /mnt/wdc
total 0
[alessio-pc@fedora ~]$ ^C
[alessio-pc@fedora ~]$ lsblk -o name,type,fstype,label,size,mountpoint,uuid
NAME   TYPE FSTYPE   LABEL                   SIZE MOUNTPOINT             UUID
loop0  loop squashfs                           4K /var/lib/snapd/snap/ba 
loop1  loop squashfs                        55.6M /var/lib/snapd/snap/co 
loop2  loop squashfs                        55.6M /var/lib/snapd/snap/co 
loop3  loop squashfs                        63.3M /var/lib/snapd/snap/co 
loop5  loop squashfs                        63.3M /var/lib/snapd/snap/co 
loop6  loop squashfs                       164.8M /var/lib/snapd/snap/gn 
loop7  loop squashfs                          73M /var/lib/snapd/snap/co 
loop8  loop squashfs                       164.8M /var/lib/snapd/snap/gn 
loop9  loop squashfs                       349.7M /var/lib/snapd/snap/gn 
loop10 loop squashfs                       349.7M /var/lib/snapd/snap/gn 
loop11 loop squashfs                        53.2M /var/lib/snapd/snap/sn 
loop12 loop squashfs                        53.2M /var/lib/snapd/snap/sn 
loop13 loop squashfs                        91.7M /var/lib/snapd/snap/gt 
loop14 loop squashfs                       156.6M /var/lib/snapd/snap/sp 
loop15 loop squashfs                       157.1M /var/lib/snapd/snap/sp 
loop16 loop squashfs                       362.1M /var/lib/snapd/snap/te 
loop17 loop squashfs                       389.8M /var/lib/snapd/snap/te 
loop18 loop                                 73.1M /var/lib/snapd/snap/co 
sda    disk                                232.9G                        
├─sda1 part vfat                             100M /boot/efi              503E-D0B8
├─sda2 part                                   16M                        
├─sda3 part ntfs                            85.7G                        3C0E40810E4035E4
├─sda4 part ntfs                             625M                        1CC6C1D9C6C1B2F6
├─sda5 part ext4                               1G /boot                  1a16503d-0d1a-4d1f-a3b2-1afa2c44663e
└─sda6 part btrfs    fedora_localhost-live 145.5G /home                  2ec403ee-83dd-4cd9-a8a0-059637b3f4fb
sdb    disk                                  1.8T                        
└─sdb1 part ntfs     Volume                  1.8T /run/media/alessio-pc/ E0E42FDEE42FB626
sr0    rom                                  1024M                        
zram0  disk                                    8G [SWAP]                 
[alessio-pc@fedora ~]$ 

And my fstab entries:

UUID=2ec403ee-83dd-4cd9-a8a0-059637b3f4fb /                       btrfs   subvol=root,compress=zstd:1 0 0
UUID=1a16503d-0d1a-4d1f-a3b2-1afa2c44663e /boot                   ext4    defaults        1 2
UUID=503E-D0B8          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
UUID=2ec403ee-83dd-4cd9-a8a0-059637b3f4fb /home                   btrfs   subvol=home,compress=zstd:1 0 0
UUID=E0E42FDEE42FB626          /mnt/wdc            ntfs3            users,nofail,dmask=0007,fmask=0117,uid=1000,gid=1000    0 0

Can somebody help me figure out how to solve this? I think the fstab entry idea works, but the mount location might be wrong. Thank you

Apparently you did something wrong in your fstab.

I recommend that you use GNOME disk utility for this, you can easily add a disk to be automounted. It never failed me.

This is how my secondary HDD is mounted.

There are two things that I don’t edit by hand for now: partitions and fstab, because messing up these can be a pain. (There are others but these came to my mind now)

1 Like

Thank you @td211 ,I have reverted the changes on fstab. Unfortunately however I don’t have GNOME disk utility, since I am on KDE fedora. Is there a program there that accomplishes the same?

1 Like

You can easily install GNOME disks even if you use KDE (I use KDE too!). Simply:
sudo dnf install gnome-disk-utility

It is a very useful tool to manage disks. Helped me setup auto unlock for LUKS on the secondary drive in addition to automount. I’m not aware of a KDE equivalent.

Oh yah, I was able to install it no problem. But then I tried to mount, and restart but it doesn’t work. I get this window on the drive:

Did you choose your own values for the mount point? Actually, if I try to use that settings, and press OK, I get an error


EDIT: This worked, I only had to give permissions. Now the drive is mounted and working. Thank you!

In the “identify as” field I chose /dev/dm-1 (which matches the device). Matchig by UUID is an eyesore and makes using commands slightly harder if you use absolute paths.

1 Like

Using the device UUID is great. That does not have to match the mount point, so yes I always define my own mount point.

One question I have though is that it appears you are mounting the raw device and not a partition with a file system on the device? Is that the case or am I just not seeing the full picture?

Hey @computersavvy , it’s just my second drive where I store docs, large files etc. Nothing else really happening there. Not sure if I answered your question though

That image does answer the question. The image shows partition 1 as NTFS on an msdos partitioned device, which may be part of the issue.

NTFS file systems do not keep the linux permissions for access (neither the standard ‘ugo’ permissions or the SELinux context)

That’s right it doesn’t by default, but you can enable support for permissions on NTFS following the answer here. I haven’t tried it myself since I no longer have NTFS on my drives but may be worth it if you need NTFS for Windows compatibility.

A ten year old thread, and may or may not be up to date. I have not tried it and won’t since I also do not use NTFS.

It is worth noting that the version of ntfs that fedora supports is called ntfs but seems to have actually incorporated the ntfs-3g features.

The answer I pointed to is 6 years old and has a comment correcting it from 3 years. Sounds like a patchwork of a solution, it may work but may also have side effects on the windows side of things. I recommend a real Linux filesystem if NTFS is not required.

Sorry to both of you, but I am not understanding exactly what the issue with the NTFS is. Can you help me? And should I do something to the mounted drive?