Unable to mount an external drive

I was doing some data transfer on my external hard drive(which was previously an internal hard drive of my laptop but i replaced it with an SSD and started using it as external) and by mistake the usb connection got loosened due to me trying to move the drive a bit, and the data transfer got interrupted, since then i have been unable to mount this drive on my F39 but its working fine on my windows 10. What can be the possible issue and how can i resolve it?

Try mounting from the command line so that you get better error messages.

IN a terminal try:

sudo mount /dev/sdc1 /mnt

Post the output here in as pre-formatted text, not screen shots please.
Copy the text from the terminal and use the </> button to do this.

user@fedora:~$ sudo mount /dev/sdc1 /mnt
[sudo] password for user: 
$MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdc1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

this is the error coming up on command line, even though the compatibility of the filesystem in error message is questioned, it was working completely fine before the data transfer

The problem seems to be resolved now, i just ran “Scan and repair” on the drive in windows and its working fine now.

Wild guess from me.

I think i read somewhere that if windows fast startup is enabled the windows disk is not dismounted fully. Maybe that is the source of the errors?

This article was the first I found with instruction on how to turn off fast startup How to disable Windows 10 fast startup (and why you'd want to) | Windows Central

1 Like

If the problem returns checkout the fast startup suggestion.

1 Like

Fast startup was indeed causing me some errors like not letting fedora access the wifi drivers during installation for some reason, so i disabled it right after installation only, so i don’t think fast startup might be behind this, probably i think the disk might’ve gotten partially corrupted, maybe thats why i was unable to access it from fedora?

That sounds likely.

Its a shame that the GUI did not tell you the detail that the mount command did.

1 Like

Well command line always had an upper hand in Linux based system when compared to GUI. Especially when providing info regarding an error.

I’ve had similar issues with external SSD drives formatted as NTFS. I’ve also raised it as an issue but the NTFS people blew it off saying wasn’t their problem. Funnily it only happens with NTFS formatted drives and no other format under Linux?
Anyway, you’d be correct in doing a disk check will fix the issue…until the next time. You can do it under Windows or there’s a function under Linux Partition Managers (whatever’s included in your DE).
I think one of the issues is writing live data to the drive (i.e saving downloads to it). Try just saving to your normal BTRFS or EXT4 formatted Linux partitions, then copy everything over to the external drive at once. And obviously dismount it before removing :grin:
Hope that helps.

Yeah windows just throws a little notification that there is something wrong with the drive and lets me use it while i couldn’t even mount it on linux… Probably some NTFS compatibility issue as suggested above.
What feature are you talking about (i have gnome)? The little cog icon on disks while selecting the drive is what you meant?
Sure! Thanks for the help :smile:

I’m not too sure about Gnome as I use KDE, but I’m pretty sure they’re all fairly similar. After opening the PM, I just right click on the partition/drive in question and in that menu there’s a “Check” option. Click that and then hit “Apply” in the main PM menu. It will do a “Check and Repair Partition”.