Mounting an existing internal drive

I’m dual booting F39 and Windows. each runs on its own independent internal drive.

I have a 3rd internal drive which I’ve used for storage of projects and such on Windows. I would like to access it in Files and interestingly, I can see and browse through it but not write to it. please check the screenshot, the add folder button is greyed out.

if it’s of any importance, when I check the permissions tab in the property panel of the drive, it seems that it should work.

I couldn’t find any information about this but I’m not sure what to search for.

attaching screenshots of the gnome disk manager, might be relevant?


thanks for your help! :slight_smile:

I seem to recall that if a user has windows set to fast boot it leaves the drives in a state that shows they are dirty and fedora will not write to the ntfs file system that is marked in that way to avoid data corruption.

If you have windows set to fast boot then turn that off and try again.

3 Likes

thanks I’ll try that!

is there any ‘risk’ associated with data corruption? are you aware of any issue that can be caused by accessing the same drive with 2 different OSs?

note: this drive isn’t running windows, it’s only a storage drive for my files.

Two OSes mustn’t access a filesystem at the same time. When one of them is hibernated, a second OS is used, and then the first OS is resumed, that counts as “at the same time”. It will inevitably lead to loss of data. Windows’ “fast boot” is a version of hibernation. That’s why the Linux ntfs driver detects it and refuses to mount it read-write. Be careful that this applies both ways, and the Windows driver probably doesn’t have these safeguards. Never hibernate your Linux and reboot to Windows, that would again corrupt data on your shared partition.

As noted above, this is not related to the drive nor the files on it. It instead is related to the drive condition left when the last OS was shutdown. Fedora is smart enough to look at the flags on the drive to see its condition and prevent data corruption when not totally shutdown by windows.

ok. this is an important tip.

for now I selected the partition in the Gnome DIsk manager app and press the stop button. it no longer shows in Files. I hope that will suffice. would you recommend to reenable fast boot as well? it isn’t directly related to the safety of the data as I take it.

I don’t presume there should be a problem to partition the second disk and use one half for each OS?

NO!
If you have fast boot enabled the drive will not be writable by fedora.
The recommendation to turn off fast boot was to “Turn it off permanently”

Correct, if you shrink the windows partition and do not use it for storage of data from linux, but instead create a second partition and use it exclusively for linux then the “fast boot” issue is moot since you are not accessing a windows drive from linux. Fedora uses its own file systems and windows uses its own file systems in that case. As long as you are not crossing the boundaries of each OS’s file systems it then is immaterial how each is configured. It is critical though when using the same file system partition for both OSes.

I don’t mind the fastboot being turned off. I’m only concerned about the safety of the data on this drive.

I use this drive to store all my projects. that’s why I wanted to share it with Fedora so I could keep storing my work on it. but @kparal advised that I’d inevitably lose my data.

ideally I’d love to access the same files by both windows and fedora. or at least be able to browse through the same folders and not do a partition.

That’s not what I said. I said you must take care not to hibernate one of the systems and boot the other one. The best way is simply to disable hibernation support in Windows (including fast boot) and Fedora (if it doesn’t show up for you in Fedora, you might not even have it, because SecureBoot currently blocks hibernation). That’s all you need to do, and you can use a shared partition just fine. I use such a partition myself, no issues.

sorry for my misunderstanding and thanks for your clarification. I will definitely avoid hibernation on both systems.