Can't Automount NTFS Drive

Greetings everyone!

I have a Windows 10 PC with 2 drives (1 drive for the system and the other one for data). Successfully installed Fedora to dual boot and everything is great so far, including the notorious Nvidia driver.

But I have a problem with automounting the NTFS data drive to the Fedora. It’s tiring to open Dolphin, click the drive, and enter my password again and again. So, following the guide from, I hope I could automount the drive but found some errors instead.

As I can see from the screenshot, the partition is on /dev/sdc and the file system is indeed ntfs. But when I mount the drive using command sudo mount -t ntfs /dev/sdc /mnt/ntfs
it came out as this:


I then tried to add /dev/sdc /mnt/ntfs ntfs defaults 0 0 to /etc/fstab as the guide suggested but the same error popped out.

I’ve also made sure that the Windows system is turned off (not on sleep). Mounting manually the drive from Dolphin is never a problem.

Kindly suggest the solution to the issue. Thank you in advance! :slightly_smiling_face: :saluting_face:


I had to mount /dev/sdc2 instead, not the whole /dev/sdc.

Thanks everyone!


Added dual-boot, ntfs and removed nvidia