Window flickers on Wayland with RTX3060

Hi guys, I’ve only been using Fedora for a short time. Previously Linux Mint was my home, but now I wanted to try something new. I currently have Fedora 37 installed and use Gnome with Wayland. First of all: during the installation it did not run smoothly, all windows flickered and it was really not pleasant to install Fedora. My hopes were in the Nvidia drivers and after installing the drivers it was also much better. Fedora was now usable and I could actually do something ;D. The flickering was still present in certain applications, but was not as annoying as before. I then searched back and forth for over a week but did not find a solution to my problem. Out of interest, I then also installed Fedora on my laptop (Ryzen 7 5800U with integrated GPU), everything runs great. I’m not a pro, but I noticed that the flickering only occurs when the application is running as X11. If I force an application to use Wayland natively, there are no problems. Now I need your help, how do I get X11 applications to run without flickering on my PC?

p.S. I hardly write forum posts and will surely have forgotten some important information, but I will gladly attach anything necessary :slight_smile:

1 Like

You said you installed the nvidia drivers.

Where did you install them from?

We always recommend that the nvidia drivers be installed from rpmfusion-nonfree-nvidia-driver repo since those have been tweaked and all packages tested to work properly on fedora. Sometimes installing the drivers directly from the nvidia .run file does not work well and also requires the user to manually update the driver (reinstall) with every kernel update.

Please post the output of lsmod | grep nvidia and dnf list installed *nvidia* as preformatted text ( </> button on the toolbar above)

BTW, as I understand it the 3060 card is only supported fully with the very latest nvidia drivers and firmware so if your driver is not up to date and the latest firmware installed those symptoms seem common.

For the installation of the Nvidia drivers I used the following script for the installation on recommendation of a friend: GitHub - t0xic0der/nvidia-auto-installer-for-fedora-linux: A CLI tool which lets you install proprietary NVIDIA drivers and much more easily on Fedora Linux (32 or above and Rawhide)
I’m not sure if this was the right decision ;D

Output of lsmod | grep nvidia:

nvidia_drm             73728  28
nvidia_modeset       1208320  4 nvidia_drm
nvidia_uvm           2904064  0
nvidia              56176640  395 nvidia_uvm,nvidia_modeset

dnf list installed *nvidia* returns an error (No matching packages to list)

I am not sure what you mean by firmware, if you mean that you can update the firmware of your graphics card I have never done that in my life xD

Edit: oops my message started in german lol

This usually means you have something with nvidia in the name in the current directory.
Try again with dnf list installed \*nvidia\*

Actually the instructions from t0xic0der there and his tool work very well for installing the nvidia drivers. :+1:

I have not used that method recently but the output of the list installed command above will tell us if you have everything needed installed. The lsmod output is exactly as anticipated.

I’ll do tomorrow, need some sleep

output of dnf list installed \*nvidia\* :

akmod-nvidia.x86_64                       3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.0.13-300.fc37.x86_64.x86_64 3:525.60.11-1.fc37 @@commandline
kmod-nvidia-6.0.15-300.fc37.x86_64.x86_64 3:525.60.11-1.fc37 @@commandline
nvidia-gpu-firmware.noarch                20221214-145.fc37  @updates
nvidia-persistenced.x86_64                3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                    3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64           3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64      3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64        3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64           3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64          3:525.60.11-1.fc37 @rpmfusion-nonfree-nvidia-driver

I am not sure what your issue continues to be.
You said ‘force’ an app to use wayland, but the default config for the Workstation install is using wayland and X can only be used if the user logs in, selecting to use gnome with xorg from the gear icon at the lower right corner of the password entry screen when logging in.

This means that for a particular login session everything is using wayland by default or xorg when selected and there is no ‘forcing’ involved. It is simply the desktop manager chosen at the time of login. Whichever is chosen remains in effect thru repeated logins until the user changes it at the next login so I can not be sure exactly what you are saying.

Please explain exactly what is happening and when, in detail, so we might better understand the conditions, including which apps and what environment you are seeing the issues with.
Posting the output of inxi -Fzxx will give us some needed info.

By force I mean running this application natively with wayland (as i understood). One example is Discord. When I run Discord normally, it flickers in some places. When flickering, something is displayed for a short moment that is no longer there. If I start Discord with the following command: Discord --enable-features=UseOzonePlatform --ozone-platform=wayland there is no problem. Another example would be Spotify, the application just goes black for a short moment in between. Maybe I can upload a Video where you can see it

output of inxi -Fzxx: System: Kernel: 6.0.15-300.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc -

Poor Cam quality: check ;D

Inxi shows everything normally. In the future, when output sizes allow please post text from the screen by copy & paste into the preformatted text tags </> on the toolbar. This makes the data permanently part of the thread and does not depend upon another site to store them. Pastebin only keeps files for 24 hours by default.

It does reveal 3 different monitors, each with a different dpi and size, which could contribute to the issue. I don’t expect that but it is possible.

The video does show the flickering.

There are 3 factors at play here.

  1. The app itself. You are using discord.
  2. How the app is launched. You gave commands that are not part of the normal launch command from the app .desktop file so that is different.
  3. The desktop manager. X or Wayland. You have not shown an actual difference in the manager used since, as I stated above, the only way to use X is to deliberately select ‘gnome on xorg’ from the login screen. It seems you are using wayland and have not explicitly stated that you have tried X and tested for actual differences.

Please log out, log back in using xorg and see if there is actually any difference. This may be related to the desktop environment and may not but we cannot rule that out without explicit tests.

Point 1: I don’t have these problems only with Discord, Discord was just my first choice to show the problem. With Spotify and Goland I have similar problems.

Point 2: With the command I used I no longer have the problems under Discord, when I run it normally the problems occur.

Point 3: I will test, give me a little more time ;D

I will also test if there are differences when I use only one monitor. Next time I will use the preformatted text tags. I was worried that the message would be too long.

Well here we are again. First of all, happy new year. I just use Gnome on xorg as suggested and there is no more flicker :slight_smile:

This would indicate a problem with wayland and the nvidia drivers with the newer GPUs.

Maybe a bug report should be filed?

never done that before but i can try

Interestingly, this problem has recently appeared on my laptop as well, but I can’t reproduce it there.

I am having the same problem. I have an Nvidia RTX 3060. I have been having the issue since I switched to fedora. My problem is described here: Fedora 36 Nvidia, Screen flickering. I am not sure if that is the same problem or not.

If so, I hope you find a fix!

I am also experiencing a problem like this and I, too, have Nvidia RTX3060 as my graphics card. I didn’t get whether you’ve filed a bug, did you?

Does it also flicker when you log in using xorg?
If not then it implies something related to wayland.

No, it does not flicker under Xorg. However, Xorg has its own annoying nuances. All sorts of GNOME Shell pop-ups seem to steal window focus. This includes: top bar menus and layout switcher pop-up. And it is very annoying, because I use them rather frequently. In the end, lately, my Fedora experience has worsened drastically.