Screen Flicker Issues with AMDGPU

I’m looking for some instruction on how to troubleshoot the screen flicker I’m getting on my workstation.

The issue begins in GDM after a boot. Certain mouse movements or menu animations will be accompanied by a flicker across my screen.After logging in the issue persists and a flicker can be seen when I press the super key to open the gnome search window.

If I go into displays and change the screen refresh rate from 60 to 30 and back to 60, this usually fixes my issue, including if I log out and log back in. However, if I reboot my system, the issue comes back and I have to play with the display refresh options again.

Can I get information on where I should begin troubleshooting the issue?

System Information:
Fedora 33
Kernel 5.9.8-200.fc33.x86_64
Gnome 3.38.1 on Wayland
AMD Radeon RX 5700XT
5120x1440@60 (or 30 or 70)

lspci output:
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] (rev c1)
Subsystem: Gigabyte Technology Co., Ltd Radeon RX 5700 XT Gaming OC
Kernel driver in use: amdgpu
Kernel modules: amdgpu

Does the problem occur if you switch from Wayland to XOrg?

The issue occurs with X11, yes. Confirmed today.

i have same problem. top of monitor flickering after waking up.

Fedora 33 kde spin
Linux 5.10.16-200.fc33.x86_64
09:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] (rev e5)
(rx560 saphire 2gb)
2560x1440 144hz connected with DisplayPort-0, freesysnc on

edit: X11

I’m having the screen flickering too. I’m running an AMD 3700x and AMD 5700XT. I have it on both Wayland and X11. I saw your post on another forum Jared, and I tried using the newest kernel, which gives me a kernel panic. I then tried every kernel (started on 5.8) from 5.6 to the newest one. I thought 5.6 was going to work, I had stopped experiencing screen flickering, but I lost all audio, so I rebooted to try and go into my 5.8 kernel to see if the audio worked there, it did, I went back to 5.6 and I can’t get rid of the flickering again. I really want to use Fedora, but both versions 33, and now 34 are giving me this issue. I’m at a lost for what to do.

lspci also says I’m using the amdgpu driver.