Where's my Applications folder?

After years on Mac, I am struggling a bit.

I am using Thunderbird. I received a PDF, clicked to view it and horrible TB decided to open in a tab. Yuk. I learned that in Settings you can choose how to open PDFs. I dived in, I have options I don’t understand like System Handler. Tried it, PDF didn’t open at all after that. So reverted.

I then googled it, learned Libre Office Writer is a perfectly good PDF viewer, so went back to TB to try to set that, but can’t. I chose “Other” and it opened a Files dialogue, which in my mac days I’d have found the Applications folder and chosen the app I wanted to use. But no such thing in Fedora (first time I’ve noticed that!)

Grateful if someone could advise how to set it to use Writer, or any other recommended way to view PDFs.

Thanks

Edit: I chose the option to “save file”. I clicked the PDF, saved in Documents. Then double clicked it and hey presto, it opened nicely. This actually leads to another gripe/issue i have with modern apps (on all systems). You often can’t see WHAT APP you’re looking at! Ok, you usually just know, but not always. I had a video player open earlier after double clicking a video file, no clue what the program was called. In this instance I clicked the 3 line menu (hamburger?) and say an “About Document Viewer” so i guess that’s what I have for PDF viewing. Question remains: Why didn’t “System Handler” open it when Firefox handed it the task?! I assume it’s system handler which decides what to open when I double click the file from Documents folder? (Assumption being the mother of all mistakes of course!)
thanks

It is understandable that when one is not used to things, it can be frustrating, but as someone who’s been using Thunderbird for probably over a decade, I happen to think it’s not at all bad but actually great :wink:

It sounds like you found in settings the part where you can choose the action for PDFs and are just asking where to find the applications. One common location would be /usr/bin. It could be /usr/bin/okular or without further information I would guess in your case it’s /usr/bin/evince.

2 Likes

Hello @joeyjonnson ,
What you are referring to is MIME types What are MIME types? . It is how Gnome handles the file type associations with which application to use to open it. Normally, you would right click on the file in question and select properties to edit the associated application that opens it. As you have found out, Gnome Document Viewer is the default PDF and other document viewer, but this can be changed by you. As far as I know, there is no “System Handler” in Fedora, other than what the Desktop Environment provides, and Thunderbird should be aware of MIME types since they have been around for some time. I don’t use TB so maybe that is an option (System Handler) specific to it. I use Evolution and it opens up a PDF in Doc viewer.

1 Like

(In Gnome Workstation Legacy)
In Thunderbird open Edit > Settings and search for pdf or go to

General > Files & Attachments > search for pdf. Now it shows you the content type pdf and on the side of Action you can select what should happen.

I seem to have one, or at least TB thinks I do!

Thanks, yes that’s where I was when I posted the thread.

The options confuse me. Firstly I don’t have Document Viewer showing, only System Handler. So I selected “Use other…” and that just opened a Files window on last viewed folder (Pictures). This is where I got stuck and started missing Mac a bit where I can just select Applications folder from sidebar and choose an app to open with. I don’t have any such folder, just my home folder and its children, none of which contain apps. Hence my confusion :slight_smile:

How would I navigate in that Files dialogue/window, to Document Viewer (or anything other app)?

thanks

PS I have the same problem for WAV files and others.

Try to open the files app. While clicking on the right mouse button on a file, you can select the Application you like. I guess that is what you are looking for. If you done this try to select the system handler in Thunderbird and check if it is as you like it.

I hope this helps.

System handler is “the system opens it with the dedicated default app”. That looks like Thunderbird Flatpak and system handler is the best option here.

In the system you can set the default app to open PDFs

2 Likes

I am no further with resolving this.
I get a PDF in an email in Thunderbird. I have the settings set to “Use System Handler”. But nothing happens when I try to open the file. Document Viewer doesn’t open and nor does anything else.

I looked in Default Apps in Settings but there’s no option for PDF files.

Finally I clicked on “Use other…” in Thunderbird settings and it just opens a file manager window at my Home folder, no idea how to find document viewer from there.

Any advice appreciated.

1 Like

I guess @rb2021 already told you what to do :point_up_2:

Before you do anything just copy past the commands in to the terminal and see if this apps open.

evince is the Document Viewer.

The most simple way would be probably to check in software if you use the local evince or the one from flatpak. Just install the one where is missing and test again.

Apropos good practice is always to put some more tags to see what infrastructure you are using. You can do so while edit your Topic title and add more, or just mention what you use and we will complete them.

Tags - I have no idea how to use that or what to select. I don’t know which are relevant, if any. the only one I see which looks relevant is ‘F39 X1213’ - as I am on Fedora 39. But no idea what ‘x1213’ means so don’t want to include tags which i don’t KNOW are applicable, risking sending people in the wrong direction.

I tried that. As I said, it just opens Home folder, no idea how to get to any ‘usr’ folder from there. I know it’s up a level, but can’t see how to get up a level from the dialogue:

Actually that’s a question I had for another topic but since it’s relevant… How do I get a permanent shortcut in sidebar in file manager, to take me to the hidden/system folders?

What commands? I dont see any commands anywhere in this thread.

I didn’t know that.

Final question - if Thunderbird is set to ‘use System Handler’ - any idea why mine won’t do so? Nothing happens, so seems like System Handler isn’t working properly, which could be a machine issue (Lenovo Yoga 16" 16ARP8), as I have similar issues with notifications - when i click them they usually don’t open the relevant app (such as Software for updates)

1 Like

evince and ocular are two applications. If you type this in a terminal it should open this app. We just delivered you the absolute path to the app, this is important when the app’s path is not available thru the path/env variables. This path you get when you type in terminal whereis evince for example

If you use a immutable Fedora version you might get a problem because of messing up or missing env/path variables.

That’s why I proposed you to give more information about your system.

Again in terminal use hostnamectl to get a quite good overview about your system inkl. kernel and Fedora Linux version/spin/lab.

If you can deliver an inxi -Fzxx is even better. Please not forget if you post some text with copy and paste, that you format it as preformated text (see </> symbol in the discourse’s editors menu)

Do not give up to ask here, but please, be from the beginning on more specific about your infrastructure. This two last commands I gave you, will help you also with other requests/topics.

This thread is a “failure to communicate”.

I also have years of Mac experience at work, but many more years with Unix and Linux. I’m using Fedora 39 Workstation. Thunderbird default is to open PDF’s in Firefox. I can’t find any mention of “System Handler” in Firefox Settiings, but there is a link to Thunderbird Help which does have mentions of “System Handler” in Fedora 37. Here, Thunderbird settings shows:

Applications in Fedora are not collected in one Folder (directory), but in F39 Workstation you can see Apps by clicking on the small button at the top left of the screen or pressing the “Super” key (Windows logo key on many PC keyboards, Apple logo on Apple keyboards). You get a row of icons for common applications with a 3x3 array of dots at the right side. That array will show you all the apps configured for Gnome. There is also a text window where you can enter “pdf” and get an icon for the “Document Viewer”, a file list of .pdf files, and a list of available applications with PDF in their names.

When describing a problem it is important to provide enough detail so others can reproduce your issue.

Sorry that you need to suffer from GNOME issues… not having a working filepicker or giving apps random names but displaying different ones…

In Firefox, the about:config has some “portal” settings in there, so thunderbird too.

Thunderbird exposes these settings graphically at the bottom of the main settings page. If you change the setting for file handling to 1 is may work.

I do not see any tag if the user really uses Gnome or Gnome Silverblue and/or an other gnome based version like mate etc.? I asked for this information as @gnwiii also mentioned it:

The topic has been opened 15 days ago and is still on hold in “Ask fedora” without farther information to identify the infrastructure the OP (original poster) uses.

So, @fedorians who helping here, I ask kindly if try to help, put the focus first on gathering information alias complete the tags, before making assumptions and giving advice. If we are not able to identify the problem/infrastructure, we can not open a bug request because we still do not have any clue to classify the problem.

I propose if the OP not delivers the necessary information soon, to delete the topic or at least to close it.

If you refer to Files & Atachements in Gnome Workstation (Legacy), this has been already explained by me detailed in Request 4. Please avoid repetitions, especially if we still have doubts about the setup.

Ok so now I learned those are not just ‘names of apps’, they can be commands too. I didn’t know that until now.

That’s a handy command, I just saved it in my list of useful commands, I am very much a beginner to terminal. Question: you keep asking for ‘more information about my system’, but I don’t know what information you need. if you were to stipulate it would be far easier, such as ‘kernel version’, as I can go and learn how to find that out and post it here. All I know at this point is I am using (as already mentioned) a Yoga 16" (Model: 16ARP8), and that I am running Fedora Workstation 39.

I ran that command and get some good info, but it’s got my host name, machine ID etc, so I don’t want to just paste the entire list, just what’s necessary. I will take a guess at what you might need:

  •          Chassis: convertible
    
  • Operating System: Fedora Linux 39 (Workstation Edition)
    
  •           Kernel: Linux 6.7.9-200.fc39.x86_64
    
  •     Architecture: x86-64
    
  •  Hardware Vendor: Lenovo
    
  •   Hardware Model: Yoga 7 16ARP8
    
  • Firmware Version: LCCN18WW
    

If there is more you require I can get it.

No idea what any of that means.

I see that option on editor menu. But do you really mean I should use it when i paste ANY text?

Again, I am more than willing, once I understand what “more specific” about my “infrastucture” means. For now I will just assume that means make/model of machine, OS version, kernel version, that should be better than nothing I hope!

But back to the question, which in my last post I used a screenshot to try to make it as simple as possible, and as much as you keep saying I have already been given what I am asking for, I don’t think I have. When I tell Thunderbird to “User other…”, it opens that dialogue shown in my screenshot. Nobody has told me how to find or select the desired app in that dialogue. At least nothing anyone has said makes me think they have told me how, if I am wrong I’d appreciate knowing what I am missing.

That’s VERY useful (and news) to me, thanks.

Trying my best, I thought my last post with the screenshot was about as clear as I can make it. To further clarify, look at your screenshot of TB settings on how to handle attachments. I have exactly the same, except for some reason where yours says ‘User Document Viewer (default)’, mine says ‘Use System Handler’.

If I choose that, it does not open Document Viewer. Nothing happens at all. I’d love to know why but it’s not vital at this point, I just need to be able to open PDFs in emails, and Document Viewer will do fine, so I decided to choose “User other…” and then choose Document Viewer manually. I can’t do that (this is my problem) because I don’t know how to do so in the dialogue (screenshotted in my post above).

(‘More detail’ on the reasons why I can’t do it: What do I click on? I know the apps are in a folder not shown, and not accessbile through any of the sidebar shortcuts, so now I know ‘Evince’ is what I am looking for, I have no idea how to navigate to it. LS said in his/her last post that I have already been given a direct link to the location, yeah, in terminal! But how I use that information in the dialogue, I have no idea)

thanks

Thanks squirrel. I remember using About:Config in Firefox in years gone by to fiddle with privacy settings. But firstly I am not using Firefox (uninstalled) and secondly I don’t know how to get to about:config in Thunderbird. If I could do that, I might be able to try changing settings in there as you suggest, nice idea anyway!

Much of what is asked for can be provided by running (as your regular user) the command
inxi -Fzxx then copy & paste that as preformatted text like this.
```
paste the text here
```

Most applications install the various bits in locations as appropriate, then provide the user a desktop icon that can be used to launch that app.

Many apps also create a per-user configuration under the users home directory.

It would be of great benefit to you to peruse the various links on line to learn linux commands.
These include (among many others)

and the much larger and more detailed

2 Likes

You can check what application is associated with pdf files by doing the below in a terminal emulator. Best guess is that Gnome console or Gnome Terminal is what’s already installed.
xdg-mime query default application/pdf

It should return an application desktop file if something is associated with pdf files.

The simplest way to get around this would be to just install something that associates itself with pdf files. I’m using evince as the example below because it is what I use.
You can do this from a terminal:
sudo dnf install evince
or
flatpak install evince
or you can search for evince in Gnome software or KDE discover.

If you want to go down manually setting up the viewer from the file picker dialog you’ll need to go down to the bottom left part of the window and select other locations, and then go to computer and you should be able to find the rpm installed applications in the /bin or /usr/bin folders.

If you’re running the flatpak thunderbird you may run into sandboxing issues trying to use specific applications.

On my installation when I looked at this, libre office draw did not show up until I had installed evince. I’m not quite sure why.

2 Likes