Virtual Machine Manager Issue in Fedora KDE Plasma

I’m trying to get a Virtual Machine going to run Windows 11 for my work (don’t ask). I’m not sure if there is another forum that specializes in VMs, but I thought I’d try here first.

After going through all the steps in this in-depth tutorial (How to Properly Install a Windows 11 Virtual Machine on KVM), I keep getting this boot error (see below). Does anyone have any insight into this issue or know what I may be doing wrong?

Here are my system specs, if it helps:

Operating System: Fedora Linux 39
KDE Plasma Version: 5.27.10
KDE Frameworks Version: 5.113.0
Qt Version: 5.15.11
Kernel Version: 6.6.13-200.fc39.x86_64 (64-bit)
Graphics Platform: X11
Processors: 32 × 13th Gen Intel® Core™ i9-13900K
Memory: 62.6 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3070/PCIe/SSE2
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7D91
System Version: 4.0

As I understand it windows 11 requires a tpm module (and maybe secure boot) so it may be difficult to run in a VM. I know the vm run with the libvirt hypervisor can manage secure boot but I don’t know if it is able to simulate the tpm module.

I don’t have a copy of the windows 11 install media to test an installation with.

I just downloaded and tested installing in a VM.
The screenshot you show requires that you press a key when the first line shows and before the 6 dots are all shown. If you delay in pressing the key then boot for the installation fails. This seems to be a result of waiting for something to happen instead of doing as prompted.

Here are my notes on how to setup a VM for Windows 11.

  1. Start virt-manager
  2. File/New Virtual Machine
  3. Select “(*) Manual install” - Forward
  4. Type “Windows 11” and select “Microsoft windows 11” - Forward
  5. Set Memory and CPUs to your needs - win 11 needs atleast 2 CPUs - Forward
  6. Select of crate custom storage. Click Manage and select your .qcow image - Forward
  7. At Step 5 of 5 select “ Customise configuration before install” - Finish
  8. Click on “TPM vNone”.
    Type should be emulated
    Open Adavanced options
    Set Model: to TIS and Version: to 2.0
    Apply changes.
  9. Check that in “Overview” the Firmware is UEFI.
  10. Click “Begin Installation” at the top of the window.

Thanks for this. The “fix” was to begin the installation in the allotted time frame (the dots bit you mentioned.) It’s now up and running as it should.

I had gone through multiple tutorials on how to set up a VM. But in every one of them, they made it appear as if the desired OS should just start running right after you set it up. (Even showing as much in various video tutorials!) The part never explained was that setting it up in VMM was only part of the process. One must then actually install the OS in the environment. Regardless, lesson learned. :slightly_smiling_face:

Yep, and the installation process is different for each OS.