usb devices in gnome boxes with windows

Hi everyone,

I write this post to ask for information about a problem I encounter on gnome boxes. I tried to install both Windows 7 and Windows 10 ltsb, but neither of them for having installed Windows guest tools for Spice when I insert a USB key (usb2, usb3 etc.) and from the settings of boxes I apply the shared USB stick, this is detected in Windows, but not configured and therefore remains unusable. I wanted to know if someone has encountered the same problem and possibly help me to solve it or to virtualize windows is better to use Virtualbox?

I thank you all

I don’t know about Windows 7, but Windows 10 should by default have everything a Windows guest needs to run in a QEMU-KVM virtual machine. At least that’s the case for 64-bit Windows 10 as far as I know.

Hello znmeb,

first of all thank you for giving me feedback on my first post … I thought no one would read it. I installed win 10 ltsb … I’ll try with win 10 not ltsb and without installing Windows guest tools for Spice … that is recommended by this “guide” that I followed: https://www.ctrl.blog/entry/how- to-win10-in-gnome-boxes

I will let you know … but if you have any advice, I willingly listen

thank you very much

Win 7 Pro is currently running in Virt-Manager for me with access to USB networking devices as well as storage devices and input devices (keyboards and mice). For that I didn’t need to install the spice guest tools in the VM, they were just available when I first started the image. I use Fedora Silverblue 29, with Virt-Manager (and Boxes @znmeb :wink:) layered on the ostree.

Hi jakfrost,

I thank you for the reply, in the coming days I will try to reinstall win 7 or 10 without spice guest tools and I will check if the usb drives work example: key. I would like to understand if there is a difference between gnome boxes and Virt-Manager or is Virt-Manager just the backend of boxes? if I can avoid virtualbox and use a foss solution, it would be better.

thank you very much

P.S.: i use fedora 29 with gnome

Hello @cpu,
Gnome-Boxes and Virt-Manager are two different projects. Virt-Manager is Fedora and Boxes is Gnome. Virt-Manager comes with a suite of tools (terminal usage), and WYSIWYG with Boxes. They both handle various VM storage formats, and are both firmly in the FOSS families of projects. The LibVirt/Virt-Manager approach would be considered Fedora proper I would guess. In workstation, the last time I was running a VM was on Fedora 27 and it was one of the VM images I am currently playing around with. I was able to use either Boxes or Virt-Manager to work with the VM’s and USB was never a problem. Not to add too much to this conversation about Virt-Manager and Boxes, but Virt-Manager would normally be the choice of an admin, and Boxes was designed to be the choice of the user.

Thanks for your interest in GNOME Boxes. I’m the maintainer. :smiley:

You could try to install the spice guest agent manually from https://www.spice-space.org/download.html in the guest.

Answering your other question: both virt-manager and gnome-boxes are frontends for libvirt+qemu.

Virt-manager is designed for users who know what they are doing and have entire responsibility of making their guest work. Boxes is for the user that just wants to run an OS and doesn’t want/need to understand operating system internals, drivers, settings, and all.

Boxes is part of GNOME but I would also consider it a Fedora project. I work for Red Hat fulltime in GNOME Boxes, in doing so, I target Fedora during the development and I also maintain the Boxes RPM package.

3 Likes

@jakfrost

I thank you for your availability and for the explanations provided. at this point I will try both solutions and I will evaluate. if it works for you, I hope it will go to me too.
I will update the post if I can solve it.

thank you very much

@feborges

it is a privilege for me that the manteiner takes this post of mine into consideration, I am happy about it. after installing windows (I tried both win7 and 10) I immediately installed this sw: https://www.spice-space.org/download/windows/spice-guest-tools/spice-guest-tools-latest.exe but, as I wrote in the first post, if I attack a USB device (usb, usb3) windows (7 e 10) tries to configure it but can not and therefore can not be used.

I wrote here just to look for support from someone who maybe everything works

Thank you very much

P.S.: I also thank you for the explanations provided

Hello @feborges

I installed the same version of windows and used the same usb stick to do a test between gnome boxes and virt-manager. the result is that with virt-manager and without installing spice-guest-tools the usb stick is correctly detected by windows, while on boxes despite activating the sharing of the key, the device is not recognized and therefore remains unusable.
if you want I am available to do some tests and to give my contribution.

I wait your feedback

I can confirm the same issue with gnome boxes on Fedora 29. I used Windows 10 Pro 64bit and Parrot OS 64bit (debian based linux distro).
Passing through USB devices in gnome boxes simply doesn’t work. With Windows, no matter what USB device you use it results in driver failure. On Linux if it is a storage device, it cannot be mounted, formated and gparted will fail with I/O error when reading the device. If it is usb wifi, then there are no errors, but it doesn’t see any wifi networks.
Both Windows 10 and Parrot OS have no problems with said forwarded usb devices in VirtualBox. I have to try Virt-Manager to see if this is qemu/libvirt issue or just gnome boxes issue.

EDIT: forgot to mention that i am using spice guest tools on both virtual machines.

I think it is mostly Gnome Boxes related since I seem to be Okay with my USB based industrial networking interfaces when using Virt-Manager. But I haven’t tested everything with them yet.

Ok, tried this in virt-manager. USB Flash drives are working fine, but the usb wifi has the exact same issue as with gnome-boxes. I know the device is working fine with the OSes I tried it on (Fedora 30, Parrot OS, Windows 10). And I know it can be forwarded successfully in VirtualBox.

This is especially strange on linux systems, where it seems to be working just fine, everything looks ok, but then it sees no wifi networks at all.

Yeah I tried the Rockwell automation 1203-USB device which is for communicating with their open platform (Connected Components) and some of their PowerFlex drives, some PanelView HMI products etc… I can see the device, it is recognized by Linux, it passes thru to the VM, but still cannot connect with the software I use for it. Frustrating to say the least. I have a Schneider Electric (Modicon) job coming up and I am going to be trying to get it going again with their devices, USB industrial network device that is. I’ll post back here when I get to working on it again.