Gnome-boxes doesn't accept .iso files for VM's

Newly installed Fedora 38. I can provide any logs required.

No matter the iso I choose or options selected I can’t get it to allow me to create a VM.

I have tried both flatpak and repo versions with identical results.

Running from terminal didn’t show anything - it just stays empty as I choose things.

You mean that the create button is gray, not clickable, correct?

Hello @fbodymechanic ,
Gnome Boxes does not have as much virtualization capability as virt-manager with qemu/kvm. You could install virt-manager with sudo dnf install virt-manager

@jakfrost sure, but Boxes is supposed to work. I successfully use it when I haven’t the needings of particular features.


You are quite correct it should work. I don’t know what the iso is either and I have had not good luck with raw disk images using boxes. Plus, in all fairness, I cut my VM teeth on virt-manager using Fedora so I tend to lean on it.

1 Like


I appreciate that. I’ve been using gnome boxes for a long time though, even when I used to use kde I had the flatpak. It was easier since everything was all one simple unit.

To be honest it was working just fine. I’m starting to shuffle my components to sell off old hardware and setup a desktop, and it was working fine in my previous computer on F38, but it was an upgrade from 36>37>38. This is a fresh 38 install as of last weekend. So it could be something new since 37, or even new just from an update stand point. And again, both flatpak and repo fall in the same way. It could not even be a Fedora issue in all actuality.

I tried Endeavour, Nix, and Fedora all fail one iso from their website and 2 automatic from within Boxes.

All of VM’s I installed under boxes were downloaded as iso files and then selected as that (Install from file, first option in menu). Boxes menu options to download OS were troublesome for me so I decided to ignore it. I’ll attach screenshot of what I have working under boxes. Second advice I can give is that You are at better odds quitting boxes app before launching next OS in VM.

Until this install, it worked fine last week on F38 (noted, it’s been subsequently updated from 36).

This is a new problem either since F38 iso, or on a recent update in the last week or two that I can’t quite pin point since this is a new install.

I’ve done hundreds of Endeavour VM’s over the last couple years doing testing on gnome-boxes, with a number of others as well.

Please double check with your BIOS configuration. Make sure to enable the virtualization.

I can reproduce your case by disabling the virtualization in the BIOS.


I will check shortly. I did update the firmware recently. Will report back in a bit.

I commend you sir, thank you. I don’t recall ever changing it in the first place, but that did it. I’m currently boxing. :beers:

1 Like