Gnome-boxes (Win10) unable to share folder with Host F38

I fresh installed F38, and used gnome boxes to install win 10.
I followed the instruction to install spice-webdav, spice-guest-tools on VM.
F38 has spice-webdav installed. But I can’t get the share folder to work.
In F37 I has no problem though.
Google search showed someone might have asked the same question but the page couldn’t be loaded.
Please help!

I use guest OS is Fedora, I hope you find it informative
XML file missing webdav.

virsh edit <guest win 10>

Note that this command not root, normal user.

insert before <channel type='spicevmc'>

<channel type='spiceport'>
      <source channel='org.spice-space.webdav.0'/>
      <target type='virtio' name='org.spice-space.webdav.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='2'/>

save file.

Boot guest win10, open Files then others, wait a few minutes(10 min?), you can access share folder.

But this share folder is unstable. It happen often cannot open share folder.

Thank you! It worked!
Indeed there wasn’t any webdav in XML file, odd.
I tried editing XML file through gnome-boxes, but the edits were not permanently saved.
Using command line as you suggested worked. Amazing!

1 Like

This issue exists also for F38 Silverblue users (using Flatpak version of Gnome Boxes)
I tried to use flatpak --command=virsh run org.gnome.Boxes bug it seems there is no <channel type='spicevmc'> … .weird

Apparently someone suggests to move from Flatpak to standard version of Gnome Boxes : Gnome-boxes (Win10) unable to share folder with Host F38 - #3 by fedora30kvm

I hope there will be a solution with Flatpak at a time.