Can't use folder share in box

i have want to access a folder from /home from my ubuntu vm but i cant can anyone help i have added that but i cant

The message in your screenshot suggests that spice-webdav needs to be installed in your VM first.

1 Like

How can i do it?

I assume it’s going to be something like apt update && apt install spice-webdav but the Ubuntu package might be named something different.

1 Like

This package does not exist


1 Like

I don’t have an Ubuntu box handy, so I used a container:

podman run -it --rm ubuntu:latest bash

From here, I ran apt update && apt-cache search spice to search for the right package.

There are a number of agents, but @grumpey’s suggestion looks to be correct:

spice-webdavd - daemon to proxy WebDAV request to the Spice virtio channel

So, the solution seems to be to run this on the Ubuntu guest: apt update && apt install spice-webdavd

You may or may not have to reboot, but you might try that and see if the option then shows up for you in Boxes.