Upgraded to 37: kscreen not remembering dual screen config again

I’ve upgraded to 37, and kscreen is not remembering my dual screen positioning (one on top of other) again, and reverting to the default (side by side) after every logout. The .local/share/kscreen/control/configs/xxxxx file doesn’t contain any positioning info:

{
    "outputs": [
        {
            "id": "d0f7aa6778131f6706bb57d57905c307",
            "metadata": {
                "name": "LVDS-1"
            },
            "retention": 1
        },
        {
            "id": "f3ae2ae735d213bf7bde466596d11045",
            "metadata": {
                "name": "VGA-1"
            },
            "retention": 1
        }
    ]
}

I’ve tried wiping .local/share/kscreen, it did not help. Should I refile a bug on this? All the previous bugs seem to have been closed. Or, since I am still using X11, maybe kscreen doesn’t work anymore in 37 and I need to set up the screens in Xorg?

Operating System: Fedora Linux 37
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.2.9-200.fc37.x86_64 (64-bit)
Graphics Platform: X11

For old timers still using X the workaround is pretty easy. Using autorandr/xrandr is easier the tweaking xorg conf files because if you make a mistake in the xorg config, your window system won’t start and you’ll have to reboot in single user mode to fix it:

  • dnf install xrandr and autorandr
  • Arrange displays the way you like with kscreen in the system settings
  • Save the config with “autorandr -s [myconfig]”
  • dnf remove kscreen.
  • Reload the config with “autorandr [myconfig]” to make sure it works. Tweak ~/.config/autorandr/[myconfig]/config with a text editor if you have to, reload & save until satisfied
  • Create a file ~/.xprofile with the line “xrandr [myconfig]” in it, this will load the config when you log in.

I have a second display that sits above my laptop display. Laptop is an old Dell Vostro. The autorandr config looks like this:

output HDMI-1
off
output DP-1
off
output VGA-1
crtc 1
mode 1920x1080
pos 0x0
rate 60.00
x-prop-non_desktop 0
output LVDS-1
crtc 0
mode 1366x768
pos 300x1080
primary
rate 60.07
x-prop-non_desktop 0
x-prop-scaling_mode Full aspect

Upgraded to 40, Plasma 6, the problem persists exactly the same, uncorrected in KDE
since perhaps 10 years!
For Plasma desktop the old correction for X has obviously no effect, so clearly the bug hides somewhere in KDE.