Login Screen appearing on both displays, want only on primary display

My setup:
Fedora Linux 38, KDE Plasma (version 5.27.5)
Nvidia GTX 1060 6GB, both displays are connected to this card.

The login screen appears on both of my monitors. I would prefer it display only on my primary monitor. I don’t see any setting to change or fix this. I’ve played around with sddm settings from various Google searches and ChatGPT answers, but nothing has worked.

I’d appreciate any feedback on how I can fix this.


1 Like

With workstation and gnome the settings panel allows one to configure the use of the monitors.
(primary or not, mirrored, right - left - above - below). Surely there is a similar control panel in KDE for the monitors. Your description seems to indicate yours may be set to mirrored.

Displays not mirrored. When I installed Fedora Workstation w/Gnome desktop, the problem did not occur. I’ve reviewed the KDE settings pretty thoroughly, unless it’s hidden, I cannot find a setting to make this change. I do have a primary display defined, but this setting alone doesn’t seem to make any difference.

Yes there is. But until you login kde plasma is not running.

If this can be configured that will be a setting in the program that does the login.

Yes there is. But until you login kde plasma is not running.

I’m not sure that reply makes sense. KDE login screen IS KDE. What am I not understanding?

The login screen is configured system wide.
Once you login your user specific settings are used.

System-setting != User-settings.

Yes, that much is obvious. I’ve attempted to adjust sddm settings under /etc and whatever GLOBAL display settings in the System Settings app. The KDE and Gnome Settings app contain both local and global settings.

I was not aware KDE had a global settings option, but regardless I also want to configure my login screen display settings.