Upgrade to Fedora 34 Wrecked the Computer

Hello all,

I tried to upgrade to Fedora 34 this morning, and there was a catastrophic failure that’s left my computer pretty much unable to boot. Here’s the situation:

  1. Fedora 33 will run on a thumb drive without a problem.
  2. Fedora 33 has been loaded on my hard drive, but it will not boot from that drive.
  3. The computer doesn’t seem to recognize the hard drive anymore.
  4. Boot sequence is UEFI
  5. SATA Operation set to AHCI
  6. Secure Boot Enable is checked.
  7. If I try to add a boot option in the Boot Sequence screen, it says, “File System Not Found!”
  8. I’ve run the available hardware diagnostics, and have found nothing wrong.
  9. I have the original SSD that was included with the computer, as well as a 1TB drive that I installed after purchase. The data on the 1TB drive is still there an intact, and I can access it if F33 is running from the thumb drive. The original drive was really only used as a boot drive, where the
  10. I wiped the original drive earlier today to start fresh.
  11. This is on a Dell laptop that’s about 2 years old.
  12. This is not a dual use machine. The only OS on this is/was Fedora.

I’m not sure what to add. I seem to vaguely recall changing something about the drive when I installed it (RAID to UEFI? I don’t remember). I’m sure there’s something in the BIOS that’s causing this problem, or maybe the drive configuration is making the computer think that the drive doesn’t exist. I just don’t recall how I fixed that last time, and I can’t seem to find it anymore.

Any assistance would be greatly appreciated.

Thanks in advance.

Welcome to the community @mark_4433 !

It looks like that you have made this in point 5. As I remember the option is to set from RAID to AHCI.

So i guess you are using a low cost SDD who not get recognized by Fedora, i was reading in some topics that you have to add something to the boot sequence/GRUB that afterwards Fedora sees it.

I tried to search for the Topic but could not find it.

Have you tried chroot or systemd-nspawn to attempt to fix your upgrade? You can do these from a Live USB if needed.

Are you still booting from a SSD, did you set up a RAID in your bios? Is the option set to AHCI or SATA ? If you have both drives installed, which one did you choose to install the OS from?

Just a thought have you tried to disable secure boot

1 Like

If you had to switch from raid to ahci, then it is also possible the machine uses RST (intel Rapid Storage Technology). Although I do not use Dell, I seem to recall that the RST has to be disabled as well.

As has been noted, secure boot also can interfere.

1 Like

I thought I mentioned this in my post, but the machine had aFedora installation previously, so i edited my post.