Can't install Fedora 34 in UEFI mode (SSD not recognized)

I have a Dell XPS 15 (9575) and I need to install Fedora on it in UEFI mode for complicated reasons related to vfio passthrough.

Unfortunately, when I boot my Fedora thumb drive, my NVME SSD is not detected in the installer. Not even in lsblk actually.

I also checked dmesg, but it didn’t really look suspicious. The only difference in dmesg regarding errors when booting in UEFI vs legacy was that I got “i915 0000:00:02.0: [drm] ERROR CPU pipe A FIFO underrun” in legacy mode, but not in UEFI mode.

I’ve already disabled Secure Boot in the UEFI.

When I enable legacy boot in the UEFI I get a warning saying “Trying to install any legacy operating system will prevent the system from booting. Only Windows 10 and Linux operating systems in UEFI boot mode are supported.”
It also explicitly says that legacy boot is only supported for booting from external devices.

When I enable legacy boot and boot my Fedora thumb drive it can actually see the SSD.

I remember having similar issues with that with previous versions of Fedora. The only reason I have a UEFI bootable Fedora on my old Gigabyte notebook is that I installed it on a different device and then transplanted the drive.
(Coincidentally a friend told me yesterday that he had to do the exact same thing for a Fedora install on his Lenovo notebook 3 years ago.)

Another solution I read about online is using an external DVD drive and booting from that in order to install Fedora, but I don’t own one and besides that it seems wasteful.

Is there a better solution? Why is this even happening in the first place?

(I wrote the fedora iso to my thumb drive using balena etcher instead of the Fedora Media Writer, because last time I used it, it had a very high chance of creating corrupted install drives. I never had any issues with Balena Etcher.)

UEFI boot (installer):

UEFI boot (lsblk):

UEFI boot (dmesg):

Legacy boot (installer):

Legacy boot (lsblk):

Legacy boot (dmesg):

UEFI legacy warning

1 Like

Please check the SATA mode in BIOS is in AHCI.


Thank you that actually did the trick! Surprisingly it was set to “RAID” which seems odd considering that this notebook has just one NVME SSD and no slots for anything else.

1 Like