Update Fedora 39 > 40 not working


I’m trying to update from f39 to f40.

I’m on a Lenovo thinkpad and the update downloads just fine, either via software or via terminal. But when I then run sudo dnf system-upgrade reboot or reboot via software, nothing seems to happen. I just get the Lenovo logo and a boot like normal.

Are there any logs I can find anywhere?

You have several possibilities.

You can inspect /var/log/dnf.log

You can check the system-upgrade log. Get the list of the upgrades and display details by providing the number of the upgrade.

dnf system-upgrade log
dnf system-upgrade log --number=1

Or just dnf system-upgrade log --number=-1 to show logs from last upgrade attempt.

You can have a look at dnf history which is not limited to upgrades only. List the entries and then display details of the one you are interested in by providing its number. Passing the output to less makes it easier to scroll and read.

dnf history --reverse
dnf history info NUMBER | less

And you can also check the journal with something like:

journalctl -S 2024-04-24 -u dnf*

-S = since date so you don’t have to list through the whole history
-u = the unit you are interested in, mind the asterisk at the end

1 Like

When you reboot have you tried hitting the esc or the shift key to show the Fedora boot settings.It may give you the option to finish the upgrade.

Welp, I swear I’ve tried more than 10 times when I made this post. Saw empty logs so figured I’d try one more time and it worked. As far as I know I didnt change anything, but it works now! Thanks anyways!