Can't update from fedora 38 to 39


Hello everyone.
I can’t update from Fedora 38 to 39. I have installed all updates and upgraded my system (several times to ensure all is ok and ready).
Can’t update using GUI/terminal commands (Follow official instructions with dnf system-upgrade). After Fedora 39 download try to restart&update, but during the updating process nothing happens.
It’s rebooted again and there’s no option to launch Fedora 39 in the grub menu. (I have a system with Windows and Fedora (previously it was ubuntu & windows, but I switched, cause it doesn’t support my motherboard)).
No errors or problems were displayed during the update.

Where should I look to find the root of the problem or what are my next steps?

did you follow the steps outlined in Upgrading Fedora Using DNF System Plugin :: Fedora Docs? (You cannot simply reboot, you need to initiate the upgrade by using sudo dnf system-upgrade reboot).

You can find logs of dnf in /var/log/dnf.log.

1 Like

Hello, yes, I followed this guide but wrote it differently for brevity.
These logs, which I previously saw during the update process, were nothing bad or interesting, all necessary dependencies were installed.

After this step sudo dnf system-upgrade reboot system reboots 2 times and after this, I don’t see any changes in Grub and Fedora.

If you followed the instructions and the download step completed properly, followed by the reboot step it should have completed the upgrade.

Two things will confirm the upgrade worked.
cat /etc/fedora-release should show Fedora release 39 (Thirty Nine)
uname -r should show something like 6.5.12-300.fc39.x86_64
Note the name fc39 in that kernel version.

If you have those then the upgrade did complete and the system seems to be running Fedora 39.

There is very little difference in the performance of the system, though it may have changed the background to the fedora 39 version if you are using a default background on your desktop.

I don’t have option to start Fedora 39 in grub, may be I should add it (but during kernel updates new versions of Fedora were automatically inserted into Grub menu).

After the update, I’m just simply rebooting to the same system, not 39.
If it were updated I’d know that fact.

please show us output of cat /etc/fedora-release, uname -r, rpm -qa \*kernel\* and feel free to run sudo dnf distro-sync. Also you need to have a look at the log files to find out what really happened during upgrade.

Fedora release 38 (Thirty Eight)



run the upgrade process again (sudo dnf system-upgrade download --releasever=39 and sudo dnf system-upgrade reboot) . After rebooting, during the upgrade process, press ESC to monitor what’s happening. Look at the logs. There will be messages in case the upgrade doesn’t proceed as expected.

1 Like

Last, what I’ve seen

watchdog0: watchdog did not stop!
(sd-remount)[1141]: Failed to remount `/` read-only: Dvice or resource busy
watchdog0: watchdog did not stop!
systemd-shutdown[1]: Failed to finalize file systems, ignoring.

After these lines system reboots again

In addition please show us the output of ls /boot/efi
It seems there was a change between f38 and f39 that might interfere with properly installing new f39 kernels so we need to check that directory structure.

Are you on Fedora Silverblue?

Is this install on SD card? read-only is an indication that something is wrong with the file system, and therefore mounted as read-only.

 EFI   mach_kernel   System  'System Volume Information'

It’s with sudo, without it prints that Permission denied

Fedora Linux 38 (Workstation Edition)

No, windows and fedora are both installed on 1 SSD.

Both systems???

Did you install 2 fedora systems on the same drive, or dual booting with windows, or exactly what is the arrangement?

This needs more clarification of what the arrangement is.

Sorry, I’ve corrected the inaccuracy in the statement.

You will have to study the logs and try to understand why filesystem is mounted RO. What’s your file system?
Gnome provides the gnome-logs app, or use journalctl, or use something like sudo journalctl -b -1 | egrep -i -A4 -B2 'ro|failed'

Nov 27 18:54:39 fedora audit: PROCTITLE proctitle="(dnf-3)"
Nov 27 18:54:39 fedora (dnf-3)[1078]: dnf-system-upgrade.service: Failed to execute /usr/bin/dnf-3: Permission denied
Nov 27 18:54:39 fedora (dnf-3)[1078]: dnf-system-upgrade.service: Failed at step EXEC spawning /usr/bin/dnf-3: Permission denied
Nov 27 18:54:39 fedora systemd[1]: Starting fwupd-offline-update.service - Updates device firmware whilst offline...
Nov 27 18:54:39 fedora systemd[1]: Starting packagekit-offline-update.service - Update the operating system whilst offline...
Nov 27 18:54:39 fedora systemd[1]: dnf-system-upgrade.service: Main process exited, code=exited, status=203/EXEC
Nov 27 18:54:39 fedora systemd[1]: dnf-system-upgrade.service: Failed with result 'exit-code'.
Nov 27 18:54:39 fedora pk-offline-update[1080]: another framework set up the trigger
Nov 27 18:54:39 fedora systemd[1]: Failed to start dnf-system-upgrade.service - System Upgrade using DNF.
Nov 27 18:54:39 fedora systemd[1]: dnf-system-upgrade.service: Triggering OnFailure= dependencies.
Nov 27 18:54:39 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=dnf-system-upgrade comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Nov 27 18:54:39 fedora systemd[1]: packagekit-offline-update.service: Deactivated successfully.

smth with dnf update

This could be a SELInux issue, see Fedora 39 Upgrade not starting - permission denied /usr/bin/dnf-3 - #23 by barryascott

Use the commands given in that post to relabel SElinux contexts:

sudo touch /.autorelabel
sudo reboot

Alternatively, you can temporarily set SELinux to permissive, see No upgrade executed when doing system-upgrade reboot - #4 by vgaetera


Thank you very much @augenauf

sudo touch /.autorelabel
sudo reboot

This solved my issue. Now I’m on Fedora 39)
You helped me a lot, how can I thank you?

1 Like

We reward each other by liking each others’ posts (which helps with badges on this forum) and passing it on—i.e., helping others :slight_smile:

1 Like