Upgrading from 39 to 40 and hit some issues

HI guys

i tried the usual steps with upgrades, but it doesnt seem to have worked

dnf system-upgrade download --releasever=40 --allowerasing --downloaddir=/storage/upgrade/
dnf system-upgrade reboot

it does a reboot and hasa progress bar, but when i come to check if there is any fc40 packages, there is none, also when i do a dnf update, it lists many fc39 packages,

when i check the /etc/os-release and /etc/fedora-release it says 40. looks like the desktop gui has changed somewhat,

im a bit clueless as to what has happened here

appreciate some help


You selected a non-standard location to store the downloaded packages. Is that location on the main drive with / or is it an additional drive that may not be mounted during the final reboot phase of the upgrade.

1 Like

Welcome to Fedora @alienkidmj12

Best is to follow the Manual:

Might be that dnf or the user you make the install with, not has right to the directory?

I do believe you do not have to use the extra path … it will download to a default location anyway.

on the same drive,

root@vanir:/boot# df -h
Filesystem                       Size  Used Avail Use% Mounted on
/dev/mapper/bifrost--vg-root      40G   33G  7.2G  83% /
devtmpfs                         4.0M     0  4.0M   0% /dev
tmpfs                            5.8G  184K  5.8G   1% /dev/shm
tmpfs                            2.4G  1.8M  2.4G   1% /run
tmpfs                            5.8G  2.1M  5.8G   1% /tmp
/dev/sda1                        495M  394M  102M  80% /boot
/dev/mapper/bifrost--vg-storage  181G  169G   13G  94% /storage
/dev/mapper/bifrost--vg-var       10G  7.0G  3.1G  70% /var
/dev/loop0                       128K  128K     0 100% /var/lib/snapd/snap/bare/5
/dev/loop4                        92M   92M     0 100% /var/lib/snapd/snap/gtk-common-themes/1535
/dev/loop3                        75M   75M     0 100% /var/lib/snapd/snap/core22/1380
/dev/loop1                        56M   56M     0 100% /var/lib/snapd/snap/core18/2823
/dev/loop2                       165M  165M     0 100% /var/lib/snapd/snap/gnome-3-28-1804/198
/dev/loop5                        39M   39M     0 100% /var/lib/snapd/snap/snapd/21465
tmpfs                            1.2G  140K  1.2G   1% /run/user/5001
root@vanir:/boot# vgs
  VG         #PV #LV #SN Attr   VSize   VFree
  bifrost-vg   1   4   0 wz--n- 237.00g 4.00m
root@vanir:/boot# lvs
  LV      VG         Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  root    bifrost-vg -wi-ao----  40.00g                                                    
  storage bifrost-vg -wi-ao---- 181.00g                                                    
  swap    bifrost-vg -wi-ao----   6.00g                                                    
  var     bifrost-vg -wi-ao----  10.00g                                                    

i did 37 to 38, 38 to 39 exactly the same way as this and it worked

i do stuff like this as root, i wouldnt chance doing it with sudo .

i am doing it this way as i dont believe i have enough space in / or /var

1 Like

If you not configure the sudoers.d for your user and limit the rights you have, you are as root with sudo.

At least I do it always this way. I never had problems.

i do

su -

then the upgrade commands

no more advice ? cheers

according to dnf system-upgrade log --number=1

it looks like upgrade was completed, but unsure why dnf it still trying to install fc39 packages.

I took the liberty of editing your post above to add the preformatted text tags so it is more readable and shows as displayed on screen. Please post text that you copy&paste using the </> (preformmatted text) button on the tool bar to retain the on screen formatting.

Note that /storage is showing as 94% full.
No file system on linux should ever be that full for performance reasons.
/ is showing 83%, /boot is at 80%, and /var is at 70%.

Your entire system is nearly full and really should be cleaned up or enlarged. You do not have a separate file system showing for /home so it appears to be part of the root file system as well.

You probably could gain space in the root file system with dnf clean all to purge leftovers from doing updates as well as potentially removing unnecessary data from your home directory.

The command vgdisplay would show the entire VG and its current allocation as well as indicating whether it contains unused space to allow expansion of any of the current LVs. If there is not space to expand then maybe something in /storage could be removed to allow extra space there for normal operations.

This would seem to indicate that the upgrade did not complete properly.
What is the output of cat /etc/fedora-release, cat /etc/os-release, and cat /etc/system-release

im aware it is full, it is a laptop ssd, im working with what i have currently, the upgrade reports that indeed fc40 package were installed, but yum db does not list it, only fc39, im a bit confused here.

ok, i am running kernel 6.8.9-300.fc40 which i believe is from fc40, but my yum list does not show this, i wonder if i have some package db issue ? can i be regenerated i wonder ?

First you need to solve the problem with the space. Cleaning temp files, caches and see if your download folder is populated with ISO Files you could delete. Or make some order with snapd, do you really still need the (/var/lib/snapd/snap/gnome-3-28-1804) ?

After this you can reinitialize the update process again an check if it still is downloading files. If there is not enough space it will just interrupt the update.

There is still the Link to the doc, just keep an eye on that so that we can better give you advice while telling us what you are doing and where you get knocked off the Update process.