Unreal Engine with KDE spin not respecting scaling or dpi

So I’m trying to use unreal engine on 38 install with a KDE spin using nvidia graphics and Xorg. Unfortunately, everything is huge sized in unreal. Does anyone have any ideas? I’ve got scaling set to 100% and dpi set to 92 in KDE settings. All other apps I’ve used look right.

Found the issue, bug in Unreal. You can run the engine though by adding -nohighdpi to the command line when launching.