Unbootable Fedora 35 livecd with livecd-iso-to-disk (dracut error)

Hi. I’ve created a brand new Fedora 35 pendrive livecd with livecd-iso-to-disk and it fails to boot with:

[    5.336301] fedora kernel: sd 3:0:0:0: [sdb] Attached SCSI removable disk
[  132.467148] fedora dracut-initqueue[637]: Warning: dracut-initqueue: timeout, still waiting for following initqueue hooks:
[  132.469413] fedora dracut-initqueue[637]: Warning: /lib/dracut/hooks/initqueue/finished/devexists-\x2fdev\x2fdisk\x2fby-uuid\x2ffe1a-f475.sh: "[ -e "/dev/disk/by-uuid/fe1a-f475" ]"
[  132.469413] fedora dracut-initqueue[637]: Warning: /lib/dracut/hooks/initqueue/finished/devexists-\x2fdev\x2froot.sh: "[ -e "/dev/root" ]"
[  132.473078] fedora dracut-initqueue[637]: Warning: dracut-initqueue: starting timeout scripts

It was a clear installation on a 8GB pendrive with:

sudo livecd-iso-to-disk --efi --format --home-size-mb 200 /tmp/Fedora-Workstation-Live-x86_64-35-1.2.iso /dev/sdb

The problem happens all the time for me (2 computers, 2 different pendrives). That command works fine with Fedora 34 and some earlier versions.

More details from rdsosreport.txt:

total 0
<<... removed other sda - local drive - partitions ...>>
lrwxrwxrwx 1 root root 10 Nov  7 11:05 E319-XXXX -> ../../sda6
lrwxrwxrwx 1 root root 10 Nov  7 11:05 FE1A-F475 -> ../../sdb1
/dev/sdb1: LABEL_FATBOOT="LIVE" LABEL="LIVE" UUID="FE1A-F475" BLOCK_SIZE="512" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="xxx-redacted-xxx"
<< ... other local sda partitions ... >>

while dracut-cmd clearly expects "[ -e "/dev/disk/by-uuid/fe1a-f475" ]" UUID with lower case (which is not available).

Is it a known issue with (dracut in) Fedora 35? I wasn’t able to find a related bug.


Try to follow the official Fedora documentation:
Preparing for Installation :: Fedora Docs
It provides tested and working methods.

1 Like

Thanks Vladislav. I know, there are some other methods, however, livecd-iso-to-disk provides some advanced options, such as encrypted persistent home partition or multiple OS versions on the same pendrive.

The ISO image itself seems to be fine - I was able to boot from ISO with qemu-kvm, but based on the logs, there might be some regression in dracut(-cmd) between F34 and F35. I temporary switched back to Fedora 34 with my emergency livecd, but it would be good to catch it and fix.

1 Like

Btw, I have found something slightly similar in the Bugzilla: 1892528 – Booting Fedora 33 install media fails with fedora dracut-initqueue[580]: Warning: dracut-initqueue timeout - starting timeout scripts

Nevertheless, it might be only similar.


A short uppercase UUID is a sign of non-native file systems like FAT and NTFS.
This could be the result of the following conversion to lowercase:

This kind of usage scenario is likely unexpected and requires patching.
So, it is best address the issue directly to the Dracut developers:
Issues · dracutdevs/dracut · GitHub

1 Like

That makes sense. UUID for “native” file systems are lowercased.

I don’t know if dracut supports “vfat”, however, livecd-iso-to-disk could also perform better in that case. According to the documentation:

–format [sizemb[,fstype[,blksz[,extra_attr,s]]]]

Partitions and formats the target device, creates an MS-DOS partition table or GUID partition table (GPT), if the --efi option is passed, creates 1 to 3 partitions, and invokes the --reset-mbr action.
NOTE WELL: All current disk content will be lost.

Partition 1 is sized as requested or as available & fstype formatted. fstype may be: ext[432](ext4 default)|fat|vfat|msdos|btrfs|xfs|f2fs (extra_attr,s may be passed to f2fs formatting, for example, --format f2fs,-,extra_attr,compression Until GRUB’s f2fs.mod is updated, any extra_attr will require booting with an EFI Boot Stub loader, such as the one from dracut triggered by the above format request.) Partition 1 is labelled as before or requested, flagged as bootable, and may allow an optional block size.

Partition 2 is fat16 formatted and labelled ‘EFI System Partition’.

Partition 3 is HFS+ formatted and labelled as ‘Mac’.

Creation of partitions 2 & 3 is dependent on the presence of the files /images/efiboot.img & /images/macboot.img in the source.

I would expect one at least two partitions in a default format execution (at least with --efi). One for data (ext4) and one for EFI (fat16). However, there is just one partition created - vfat/fat32 (named EFI System Partition) which also limits an ability to reuse host space by an overlay layer.

Btw, the source ISO for Fedora 35 contains both efiboot.img and macboot.img.

Updated. There is even an issue for vfat and --efi - How to prevent `VFAT` from being used when specifying `--efi`? (livecd-iso-to-disk) · Issue #208 · livecd-tools/livecd-tools · GitHub.

I’ve run into a similar problem with the boot timing out waiting for a “/dev/mapper/live-rw” job using the following command line to created the Live-USB:

livecd-iso-to-disk --format --reset-mbr --skipcompress --no-overlay --timeout -1 Fedora-Workstation-Live-x86_64-35-1.2.iso /dev/sdf

Have you found any work-around or have you reported the bug anywhere? If not, I’m planning on reporting it to the Fedora livecd-tools

1 Like


I 've run into similar issues while following the syntax provided by livecd-tools/livecd-iso-to-disk.
Have you considered opening an issue directiy to the project:
livecd-tools ?
This tool set (livecd-iso-to-disk and editliveos) is very powerful but the syntax presented might need more explanations and examples for some users (I’ve been tweaking with them for a couple of years now but I’am still a beginner)

I might do that too. thanks for the heads-up.

@linesteppr It turned up that probably vfat is problematic and with ext4 it worked fine (might be worth to report a bug, anyway!). However, to make it work, I had to:

  1. Use --efi --format ext4 as suggested here. I believe, I had to use the upstream version from GitHub - livecd-tools/livecd-tools: Tools for building live CDs using DNF as Fedora one failed with that.
  2. Apply patch from the following MR - to prevent that error: livecd-iso-to-disk, editliveos: Add option to skip macboot.img proces… by FGrose · Pull Request #217 · livecd-tools/livecd-tools · GitHub

In the end the following command worked for me:

livecd-iso-to-disk.sh --efi --format ext4 --nomac --home-size-mb 200 /tmp/Fedora-Workstation-Live-x86_64-35-1.2.iso /dev/sdb

Of course, there might be some other issue in your system. I encourage you to report a bug in that case.

Btw, I also created the following enhancement proposal: First partition for "--efi --format ext4" should have type "Linux partition" not "EFI System"? · Issue #219 · livecd-tools/livecd-tools · GitHub (which might be also applied manually on the file system).

OH! … ok. I didn’t notice that from your previous post that there were arguments to --format. I’ll definitely give that a try.

1 Like

Note also the --efi in there. If your machine uses uefi then that is needed as well.

Note also the --efi in there. If your machine uses uefi then that is needed as well.

Yes, however, what is nice, livecd-tools does some magic and that pendrive is able to boot also on an old BIOS-based machine.

Yes, I saw that the --efi causes it to create the hybrid boot so it can be either legacy or efi boot.

Also good to know as I have both. Ten year-old AMD Phenom II hexa-core runs Fedora 35 surprisingly well.