Fedora failing to boot: dracut-initqueue timeout


I was trying to extend my LVM fedora partition as there was free space left on my drive. However, I have only ever worked with normal partitions and not with LVM partitions and so something went wrong, leading to Fedora 31 not being able to boot anymore. Instead, after selecting the Fedora 31 Grub boot entry, the Fedora logo and the spinning circle appear but nothing happens. When I hit F3, after a few minutes the dracut-initqueue timeout warning appears. If I then type exit, Fedora 31 boots and I can log in. How can I fix this and how did this happen?

In GRUB: Did your removed “quiet” and “splash” from “command line” (to see most of messages)?

Yes, and I was also able to save the rdsosreport.txt file, which I uploaded here. I just looked through it and it seems like it’s missing a swap partition from my old fedora installation. Could this be the problem?

There are two swaps, /dev/sda3 and /dev/mapper/fedora_new-swap which is on either /dev/sda7 or /dev/sda8 (both of those are LVM PVs, making up the fedora_new VG).

Command line refers to two swaps:
rd.lvm.lv=fedora_localhost-live/swap rd.lvm.lv=fedora_new/swap

Journal says
[ 137.919698] localhost.localdomain dracut-initqueue[501]: Cannot process volume group fedora_localhost-live

I suspect /etc/default/grub needs updating, followed by recreating the grub.cfg. Either post /etc/default/grub, or edit it so it only contains rd hints for VG/LV’s that exist. And then recreate the grub.cfg with grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg and see if that fixes the problem.

1 Like

Thanks! I don’t really know how to edit grub. To fully explain what I did to cause the error was to delete a fedora volume group of an old fedora install I wasn’t using anymore. I thought trying to enlarge my current Fedora volume group caused the error, but apparently it was the unsuccessful deletion of the old Fedora volume group. Anyway, the new Fedora install is fedora_new and the old one is fedora-localhost-live, which I want to get rid of completely, so that I can then enlarge fedora_new.
Below you can see my grub:

GRUB_DISTRIBUTOR=“$(sed ‘s, release .*$,g’ /etc/system-release)”
GRUB_CMDLINE_LINUX=“rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=UUID=6ff75312-ef2b-4a55-a6b7-58e1a0e2f79f rd.lvm.lv=fedora_new/root rd.lvm.lv=fedora_localhost-live/swap rd.lvm.lv=fedora_new/swap rhgb quiet”

Remove rd.lvm.lv=fedora_localhost-live/swap from /etc/default/grub, and then recreate the grub.cfg as I described. That’ll fix the boot failure problem.

The file you previous attached shows no sign of the old VG. Why do you think you didn’t get rid of it?

The rdsosreport file you posted shows that sda7 and sda8 are fully available in the new VG, and the VG is completely accounted for by three LV’s: home, swap and root.

/dev/sda2 and /dev/sda6 are both ext4 volumes, I suspect only one of them is needed. And also /dev/sda3 is swap and probably not needed either. Once you get the boot part fixed, post /etc/fstab and we’ll see what things aren’t used. I’m gonna guess those are partitions that weren’t removed during the reinstallation. There is an option to wipe them, and turn them into additional PVs, add them to the existing (new) VG, and then you can use that extra space for root or home. But it’s not urgent, I doubt the amount of space used by those stale partitions is more than 10G.

I didn’t know changing your grub was that easy and it worked! It’s now booting normally again. I thought I didn’t fully get rid of it because I had the boot problem. Well, now I know I also have to change my grub and how to do so, so thank you very much. The ext4 partition are from a Debian installation I like to keep around in case I mess something up in my Fedora install (like I just did). It’s a small install anyway.
Now I need to create a new PV from the freed space and turn to them to additional PVs and add them to my current Fedora install. My fstab is as follows:

/dev/mapper/fedora_new-root / ext4 defaults 1 1
UUID=c4f59661-f150-4156-a435-e12260658156 /boot ext4 defaults 1 2
UUID=7F5D-2F62 /boot/efi vfat umask=0077,shortname=winnt 0 2
/dev/mapper/fedora_new-home /home ext4 defaults 1 2
/dev/mapper/fedora_new-swap none swap defaults 0 0
#mounting windows file system on boot
UUID=B0628E59628E23E6 /media/windows ntfs auto,users,uid=1000,gid=1000,dmask=027,fmask=137,utf8 0 0

My Windows installation on another drive is automounted and I’d also like to keep it that way.

Taking both the /etc/fstab and the rdsosreport.txt into account, looks like sda1, sda5, sda6, sda7, sda8 are all used by this Fedora installation. And sda2, sda3, sda4 belong to something else. I don’t see any other free space.

Thanks a lot, I got everything sorted out now.