Long boot after upgrading kernel to 5.12.6 F34

After upgrading kernel to 5.12.6 through dnf my boot is stuck on “Starting Switch root”, and than after ~30 sec without any errors it boots into OS. Today updated to 5.12.7 and this problem is still present. Tired to switch selinux=0 and boot - same result, long waiting on “Starting Switch root”. Anyone else experiencing same thing?

I’m experiencing the same issue. On my system the boot process hangs for ~90 seconds at “Starting Switch root” with all 5.12.x kernels I tried yet. Booting kernel 5.11.19 doesn’t have this problem.

I have to add that my system is not a fresh install of Fedora 34 but it has been upgraded over the years from Fedora 27 (I think). So maybe this is related to some component that (bootloader? filesystem?) that has changed in Fedora but hasn’t been upgraded for existing installations.

I don’t think this is related to 1765297 – System become unbootable (Failed to start Switch Root) after the last upgrade because my /boot/grub2/grubenv seems to be intact.

A year ago (on Fedora 32) I added systemd.unified_cgroup_hierarchy=0 as boot arg because this was required to run Docker back then. As this is no longer the case I removed this argument from my grub config but this appears to have no effect.

UPDATE: This might be the relevant bug for this issue, no proposed solution yet: 1965725 – 5.12.X kernels fail to boot

A temporary hang means something is timing out. Boot without rhgb or quiet and see if it show what service is actually timing out.

tried to restart with rhgb and quiet option off, and still, Starting Switch root \n Welcome to Fedora 34… And waiting, than after some time rest processes starts without any errors

I have 2 machines: 1 notebook and 1 workstation and both are running fedora 34 (upgraded) and both are updated to the latest kernal 5.12.13 today. My experience with this error:

Update to 5.12.12: workstation did wait after inird, notebook was fine
update to 5.12.13: both machine are now waiting in or after initrd - rather early step

Loading of 5.12.11 on both machine: Both do boot fast

Conclusion: Something with the kernel image

HW: HP workstations and HP notebook with Intel proc and Intel on board GPU

Try this: run

systemctl-analyze blame

in a terminal and post here only the part of the output that shows times of more than a second. What you want will probably be the first one listed, but this will get us a better idea of what’s going on. Once we’ve examined that, we’ll have more info to work with.

Here the result: 1min 30.307s dracut-initqueue.service

So, it is dracut

Edit: I rebuild the initrmfs image but it does not solve the trouble. dracut says: Everything is fine.

Ok, the error is known here: Bug 1976653

We have to wait for an fix or patch the current version (see comment 4) - I will wait.

Same here but with kernel 5.13. Waiting for dracut to fix it.