Problem to mount lvm partition at boot


For several months now I have a problem on one of my fedora servers about lvm groups.
I wanted to disable the swap since it was installed on a raid1 of ssd and I wasn’t really needed swap. So to avoid the burn out of the SSD I wanted to disable it.
Which I did with swapoff , comment the line in fstab, and even delete the part of swap mentionned into /etc/default/grub
But the side effect of that was the disabling of the entire lvm group. I had the swap on it and a VM storage partition.
I can’t get them online at boot since. That was under fedora31. I4ve upgraded to fedora32. same deal.
I can activate them after the launch with vgchange -ay . That makes the trick to make the volume active.

Like described in this post, the boot hangs for the complete timer for volume to be recognized 1m30 which it doesn’t get.

my line in /etc/default/grub is
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora-swap systemd.unified_cgroup_hierarchy=0 rhgb quiet"

the fstab:
UUID=ff61bb1b-c5cc-4acc-bf54-5327d416b1a0 / ext4 defaults 1 1
UUID=377c614e-aa20-4b27-9ad5-da597ccc1781 /boot ext4 defaults 1 2
UUID=F162-7F0B /boot/efi vfat umask=0077,shortname=winnt 0 2
/dev/mapper/fedora-fedoravm /vm ext4 defaults 0 0
/dev/mapper/fedora-swap none swap defaults 0 0

Can someone tell me to reactivate the whole volume at boot? And explain to me why this is happening?
And in the end I would still gladly like to deactivate the RAM but keep my VM volume alive. IS that even possible?

Thanks in advance for all your help.

This helped me to resolve a similar issue after renaming the VG:

sudo dracut -f --regenerate-all

Thanks it worked. I didn’t tried yet while deactivate completely the swap with a drague at the end. I will keep you informed if this was also the problem for that part