Stuck while booting the Fedora Server 34 iso from an USB pendrive


I want to create a bootable USB pendrive using the Fedora Server 34 iso and I want to do “manually”. So I’ve created two partitions in my pendrive /dev/sdb: the first one is the ESP (where I’ll put the systemd-boot bootloader) and the second one is formatted in Ext4 (where I’ll put all the iso content) and I’ve put the Fedora Server 34 iso in my CD drive /dev/sr0. And then I’ve done this from my running system:

e2label /dev/sdb2 manolo
mkdir /mnt/cd /mnt/esp /mnt/iso
mount /dev/sr0 /mnt/cd
mount /dev/sdb1 /mnt/esp
mount /dev/sdb2 /mnt/iso
cp -r /mnt/cd/* /mnt/iso
bootctl --esp-path=/mnt/esp --no-variables install
cp /mnt/iso/images/pxeboot/vmlinuz /mnt/esp/EFI/systemd
cp /mnt/iso/images/pxeboot/initrd.img /mnt/esp/EFI/systemd
echo "default pepe" > /mnt/esp/loader/loader.conf
echo "timeout 5" >> /mnt/esp/loader/loader.conf
echo "title Arrencar LiveCD Fedora" > /mnt/esp/loader/entries/pepe.conf
echo "linux /EFI/systemd/vmlinuz" >> /mnt/esp/loader/entries/pepe.conf
echo "initrd /EFI/systemd/initrd.img" >> /mnt/esp/loader/entries/pepe.conf
echo "options inst.stage2=hd:LABEL=manolo" >> /mnt/esp/loader/entries/pepe.conf

When I boot from my pendrive it seems kernel boots ok until I get this message: “A start job is running for /dev/gpt-auto-root” and I get stuck in a dracut shell. Notice I’ve put exactly the same kernel parameter there is in /mnt/iso/EFI/BOOT/grub.cfg, which (I suspect!) it’s the default boot loader’s configuration file used by Fedora Server iso when booting to Anaconda. So I don’t know which kernel parameter I’m missing!

Thanks a lot

PD: I’ve read this issue 1709944 – Cannot boot; initramfs timeouts on /dev/gpt-auto-root but it’s not exactly what I have because I don’t want to boot a “regular” root partition: I want to boot Anaconda installer.

Take a look at usr/lib/dracut/modules.d/90dmsquash-live/ (from dracut-live). I think our livecds use that dracut module, and that module requires or rdlivedebug parameter on the kernel command line to do anything at all.

Thanks for the answer! I’ve tried and sadly, it doesn’t work: the behaviour is the same. I suspect you’re talking about Fedora Workstation iso but I want to boot a Server one.

Anyway, I’ve solved this issue (kind of)!! I’ve put the Linux x86_64 GUID to /dev/sdb2 and that’s all.
I mean, I’ve run fdisk /dev/sdb and, inside its shell, I’ve choosen “t”->“2”->“23”->“w” (number 23 is the identifier for desired GUID, 4F68BCE3-E8CD-4DB1-96E7-FBCAF984B709). After that, now Anaconda boots. But this behaviour isn’t documented anywhere and I think it’s a bit tricky: someone should be study this with more care. I drop these lines here to document it.

Thanks a lot!!