Unable to wake from sleep on F37

I have my F37-Gnome (along with Arch Linux and Elementary OS) on Lenovo Thinkpad P15s Gen1 with an Nvidia Quadro P520 card. The fresh install of F37 worked fine until I decided to apply three firmware updates at once recommended by Software. This bricked my machine, and luckily, I could recover from it through the Fn + R and power key, as suggested in various other posts. Since then, I have lost sound and the ability to suspend on all three concurrent installations. Please help me debug this issue. I have the latest proprietary Nvidia driver (525.89.02), and I have even tried suspending the system after removing the driver, but to no avail.

Once I suspend via systemctl suspend, my display is powered down, the LED indicators on my keyboard go off, and the indicator in the power key starts blinking. This takes about ~10s, and when I try to wake up the system using the power key, the LED indicators on my keyboard turn on, but the screen remains blank and the power button indicator still keeps blinking, even when I wait for a few minutes. I have temporarily masked the suspend and hibernate options to avoid hard reboot every time I leave my computer. I have tried this on the multiple v6+ kernels on my system, and none of them seem to be able to suspend. I tried visiting some of the websites that introduce general ways to debug the suspend issues, but none of them seem to work. For example, dmesg > dmesg_before; echo mem > /sys/power/state; dmesg > dmesg_after command mentioned here, had to adapted to dmesg > dmesg_before; echo mem | sudo tee > /sys/power/state; dmesg > dmesg_after, and this did not suspend my system at all.

uname -r


I don’t have the systemd journals for my suspend events since it is now filled with suspend requests from logind and rebuttal from systemd since the target is masked. I remember looking at the journalctl entries after hard shutdown, and there weren’t even any records of the sync operation that is normally carried out before powering down.

Sorry if the question is too big. I am on GMT +5:30 TZ, and I am going to catch some sleep, though my system currently struggles with it.

Sorry for not contributing but… what is that FN + R? Is it only a Lenovo thing?

I guess so, was desperately pouring through Lenovo forums and found this magic combo.