Desktop does not wake after sleep


I need help with my Fedora 39 machine. After reinstalling Fedora (I had Fedora 37 before), I’m having trouble waking it up after it goes into suspend mode.

Problem: When I press a key on the keyboard to wake it up, the computer starts up (fans spin), but the displays remain black. I’ve tried entering ttys, but that didn’t work either. I end up having to force shutdown my PC.

I’m using the NVIDIA driver from RPM Fusion.

Thank you in advance.

System Details Report

Report details

  • Date generated: 2024-02-06 11:00:11

Hardware Information:

  • Hardware Model: ASUS All Series
  • Memory: 16.0 GiB
  • Processor: Intel® Core™ i5-4690K × 4
  • Graphics: NVIDIA GeForce GTX 970
  • Disk Capacity: 256.1 GB

Software Information:

  • Firmware Version: 2405
  • OS Name: Fedora Linux 39 (Workstation Edition)
  • OS Build: (null)
  • OS Type: 64-bit
  • GNOME Version: 45.3
  • Windowing System: X11
  • Kernel Version: Linux 6.6.14-200.fc39.x86_64
1 Like

I did some more research and found this:

they both unfortunately do not lead to a solution.
But i am not the only one with the issues.

I have verified the problem does not occur when using the nouveau drivers.
What to do in a situation like this?

1 Like

I comment once again to raise awareness. I need some help please.

Thank you for your useless contribution.

An kernel update in the meantime fixed the issue.

1 Like

Thanks for the info @saaabo. I was facing this problem today and your answer saved me time from wandering around for some technical solution.

I was having issue within v6.7.3 of the Kernel. After upgrading to v6.7.4, the system started to wake up after a Suspend.

I am still facing this another problem that the system does wake up with external keyboard or mouse. I have to press the key on the laptop’s keyboard.

Just letting you know, I am not looking for any solution here.


1 Like

Running kernel 6.7.9 and system freezes and requires hard reboot after being suspended. My h/w is circa 2020.

I followed clues on this thread that is related to NVIDIA so decided to investigate.
I checked if any NVIDIA drivers were active lsmod | grep nvidia and there were none.
Then I checked if any were installed sudo dnf list installed | grep nvidia . There were none in both cases so I installed themsudo dnf install akmod-nvidia.
After reboot lsmod was still not showing them so I disabled Smart Boot in BIOS and tried again. This time they were loaded. So I tried nvidia-smi which turned out required extra package xorg-x11-nvidia-cuda . After that nvidia-smi worked and reported GPU usage (among other things) so I knew NVIDIA was working on Fedora. It also seems to fix the “not being able to wake up” issue. So far so good.

1 Like

I did not had this issue before but since upgrading to Fedora 40 workstation I started having this issue.

I am facing the same issue after the recent Fedora 39 updates. Has a fix been released yet?

Please start a new thread. There are many things that can cause failure to wake after sleep, so you should provide the output from running inxi -Fzxx in a terminal and then pasting as pre-formatted test using the </> button from the line at the top of the text entry window. This will help focus attention on specific hardware issues, and will also help others with similar hardware and issues find your post.

You should ensure that Fedora packages and system firmware are fully updated so you aren’t chasing a solved problem.