Unable to resume from suspend

Related to reddit thread here.

I recently bought a new laptop (Asus Flow Z13, 3050 Ti version) and am trying Fedora on it. It runs great and I am very happy with it except for one major exception: I cannot resume from suspend. Whenever I suspend the system, the screen goes black and then is unresponsive when I try to resume. Every time I have to force a shut down by holding the power button. I have tried kernels 6.6.6-200.fc39, 6.5.6-300.fc39 and 6.2.9-300.fc38 (last one has tonnes of other problems too), none have helped. When in suspend, I’m also not able to access any other tty.

I also tried changing the sleep mode to S3/deep and it did not help. I also tested Fedora 38 via a bootable usb drive but while that one could sleep, it was unusable otherwise. I think F39 is not suspending at all though, because with F38 when it suspends the light on the back of the machine kind of blinks whereas with F39 it just stays on and the screen is unresponsive.

Reading online, it sounds like this might be to do with my graphics card. I tried both proprietary and free Nvidia drivers. Here’s the output of nvidia-smi

+---------------------------------------------------------------------------------------+
| NVIDIA-SMI 545.29.06              Driver Version: 545.29.06    CUDA Version: 12.3     |
|-----------------------------------------+----------------------+----------------------+
| GPU  Name                 Persistence-M | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp   Perf          Pwr:Usage/Cap |         Memory-Usage | GPU-Util  Compute M. |
|                                         |                      |               MIG M. |
|=========================================+======================+======================|
|   0  NVIDIA GeForce RTX 3050 ...    Off | 00000000:01:00.0 Off |                  N/A |
| N/A   43C    P0             749W /  35W |      5MiB /  4096MiB |      0%      Default |
|                                         |                      |                  N/A |
+-----------------------------------------+----------------------+----------------------+
                                                                                         
+---------------------------------------------------------------------------------------+
| Processes:                                                                            |
|  GPU   GI   CI        PID   Type   Process name                            GPU Memory |
|        ID   ID                                                             Usage      |
|=======================================================================================|
|    0   N/A  N/A      2679      G   /usr/bin/gnome-shell                          1MiB |
+---------------------------------------------------------------------------------------+

Here’s my OS info:

NAME="Fedora Linux"
VERSION="39 (Workstation Edition)"
ID=fedora
VERSION_ID=39
VERSION_CODENAME=""
PLATFORM_ID="platform:f39"
PRETTY_NAME="Fedora Linux 39 (Workstation Edition)"
ANSI_COLOR="0;38;2;60;110;180"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:39"
DEFAULT_HOSTNAME="fedora"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f39/system-administrators-guide/"
SUPPORT_URL="https://ask.fedoraproject.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=39
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=39
SUPPORT_END=2024-11-12
VARIANT="Workstation Edition"
VARIANT_ID=workstation

Any help appreciated, hope I provided enough info!

After looking around, maybe it has to do with something blocking sleep?

systemd-inhibit --list --mode=block gives

WHO UID  USER PID  COMM           WHAT                                                     WHY                       MODE 
jph 1000 jph  3009 gsd-media-keys handle-power-key:handle-suspend-key:handle-hibernate-key GNOME handling keypresses block

1 inhibitors listed.

I’m not sure what this program is. Killing it, it just spawns again. I also tried Fedora with KDE Plasma since maybe this is a gnome problem, but the suspend had the same faulty behaviour (granted, I only tried from the bootable USB).

I wish I could give a more informative answer to anyone finding this thread later, but the solution was to wait. After some updates that popped up today, it works fine. :person_shrugging:

Hi,

I have the same problem. I can’t wake up and I can’t force shutdown by holding the power button.

I tried several kernel versions:

  • 6.4.15
  • 6.6.9
  • 6.6.11
  • 6.7.0

My OS info:

NAME="Fedora Linux"
VERSION="39 (Workstation Edition)"
ID=fedora
VERSION_ID=39
VERSION_CODENAME=""
PLATFORM_ID="platform:f39"
PRETTY_NAME="Fedora Linux 39 (Workstation Edition)"
ANSI_COLOR="0;38;2;60;110;180"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:39"
DEFAULT_HOSTNAME="fedora"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f39/system-administrators-guide/"
SUPPORT_URL="https://ask.fedoraproject.org/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=39
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=39
SUPPORT_END=2024-11-12
VARIANT="Workstation Edition"
VARIANT_ID=workstation

I have an AMD GPU:

I have an name of display: :0
display: :0  screen: 0
direct rendering: Yes
Extended renderer info (GLX_MESA_query_renderer):
    Vendor: AMD (0x1002)
    Device: AMD Radeon RX 6750 XT (radeonsi, navi22, LLVM 17.0.6, DRM 3.56, 6.7.0-68.fc40.x86_64) (0x73df)
    Version: 23.3.3
    Accelerated: yes
    Video memory: 12288MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.6
    Max compat profile version: 4.6
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.2
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 11124 MB, largest block: 11124 MB
    VBO free aux. memory - total: 7702 MB, largest block: 7702 MB
    Texture free memory - total: 11124 MB, largest block: 11124 MB
    Texture free aux. memory - total: 7702 MB, largest block: 7702 MB
    Renderbuffer free memory - total: 11124 MB, largest block: 11124 MB
    Renderbuffer free aux. memory - total: 7702 MB, largest block: 7702 MB
Memory info (GL_NVX_gpu_memory_info):
    Dedicated video memory: 12288 MB
    Total available memory: 20240 MB
    Currently available dedicated video memory: 11124 MB
OpenGL vendor string: AMD
OpenGL renderer string: AMD Radeon RX 6750 XT (radeonsi, navi22, LLVM 17.0.6, DRM 3.56, 6.7.0-68.fc40.x86_64)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 23.3.3
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile

OpenGL version string: 4.6 (Compatibility Profile) Mesa 23.3.3
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 23.3.3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20AMD GPU:

Thank you for your help

I’m having this exact same problem, no solution so far.

UPDATE: In kernel version 6.6.14-200.fc39.x86_64 suspend is working fine.

I’ve had similar issues with my desktop for several versions of Fedora. I don’t recall how far back. 35? 37?
The difference is that the suspend function for me is intermittent: it might work four times in a row, and the fifth time it never suspends. It stops communicating with keyboard, mouse, and screen, though.
Funny thing is that I can still often ssh into the computer! Occasionally (but rarely) will a cli command ‘systemctl shutdown’ actually shut the computer down, but mostly any power related commands will just kill the ssh server and leave the computer running, blind and deaf.
As an aside, I also run Fedora on a laptop (Dell), where I don’t have this problem, and I have sometimes run Gentoo on the desktop without problems (no, don’t ask me what kernel options I used. I no longer know / don’t care to try to figure it out. I’ve given up on that distro).