Unable to resume after suspend/sleep

Hey there!

I have an ASUS laptop with a Ryzen 5 (mobile) and Nvidia 1650 graphics. I installed F31 a few days ago, and have been having problems with resuming the session after suspending it (to the RAM). I tried every possible step (installed Nvidia drivers, updated the kernel and everything), but they don’t work for me.

I am not sure what I should pursue next. It’s my first time with Nvidia graphics and hence am unsure if it is Nvidia’s fault or not. I am now running on the Nouveau drivers (reverted back), and would like to know what should I do next.

Here’s a snippet of my grub config.

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
# GRUB_GFXMODE="1920X1080"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/fedora_localhost--live-swap rd.lvm.lv=fedora_localhost-live/root rd.lvm.lv=fedora_localhost-live/swap rhgb quiet"
1 Like

Try acpid (Ubuntu Forums thread of 2018-n)?

Update: Doesn’t helps there.

What do you get for

efibootmgr -v
mokutil --sb-state
$ efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0000,0003,0005,0006,0001,0002,0007
Boot0000* Windows Boot Manager  HD(1,GPT,8308f9d2-2bc6-42f1-a1fc-cb36186007bd,0x800,0x82000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}....................
Boot0001* UEFI:CD/DVD Drive     BBS(129,,0x0)
Boot0002* UEFI:Removable Device BBS(130,,0x0)
Boot0003* Fedora        HD(1,GPT,8308f9d2-2bc6-42f1-a1fc-cb36186007bd,0x800,0x82000)/File(\EFI\FEDORA\SHIMX64.EFI)
Boot0004* Fedora        HD(1,GPT,8308f9d2-2bc6-42f1-a1fc-cb36186007bd,0x800,0x82000)/File(\EFI\FEDORA\SHIM.EFI)..BO
Boot0005* UEFI: Generic Flash Disk 8.07 PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(2,0)/CDROM(1,0xac,0x15350)..BO
Boot0006* UEFI: Generic Flash Disk 8.07, Partition 2    PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(2,0)/HD(2,MBR,0x7aa014a1,0xac,0x54d4)..BO
Boot0007* UEFI:Network Device   BBS(131,,0x0)
mokutil --sb-state
SecureBoot disabled

Here you go. I’ll try the steps mentioned by @vits95 and will report back soon. :smiley:

Nope… Enabling acpid does not work… :confused:

  Peace & Love: If it's all works with nouveau: try to report this to the Nvidia, as they should know their p-blob better than anyone else (and take all the responsibility ;).

  Update:  down the thread a similar issues were posted -- with AMD and Intel's Graphics, too.


I am experiencing the same problem. Once the kernel got updated to 5.5.5-200, when my laptop attends to resume from sleep, the display shows horizontal lines and the system is totally unresponsive. Being patient, I wait for whatever regression has been introduced by the new kernel is resolved.
Inxi showing the relevant bits…

inxi -F -G -M
  Host: lazarus Kernel: 5.5.5-200.fc31.x86_64 x86_64 bits: 64 
  Desktop: KDE Plasma 5.17.5 Distro: Fedora release 31 (Thirty One) 
  Type: Laptop System: LENOVO product: 81N3 v: Lenovo IdeaPad S145-15AST 
  serial: <root required> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700WIN serial: <root required> 
  UEFI: LENOVO v: AYCN14WW date: 01/14/2019 
  Topology: Dual Core model: AMD A9-9425 RADEON R5 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP L2 cache: 1024 KiB 
  Speed: 1887 MHz min/max: 1400/3100 MHz Core speeds (MHz): 1: 1887 
  2: 1925 
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] driver: amdgpu 
  v: kernel 
  Display: x11 server: Fedora Project X.org 1.20.6 driver: modesetting 
  FAILED: ati unloaded: fbdev,vesa resolution: 1366x768~60Hz 
  renderer: AMD STONEY (DRM 3.36.0 5.5.5-200.fc31.x86_64 LLVM 9.0.0) 
  v: 4.5 Mesa 19.2.8 

Ahh… I was unaware of inxi. Here is the output for my computer:

System:    Host: localhost.localdomain Kernel: 5.5.5-200.fc31.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.17.5 
           Distro: Fedora release 31 (Thirty One) 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505DT_FX505DT v: 1.0 serial: <root required> 
           Mobo: ASUSTeK model: FX505DT v: 1.0 serial: <root required> UEFI: American Megatrends v: FX505DT.308 
           date: 09/19/2019 
Battery:   ID-1: BAT0 charge: 40.4 Wh condition: 43.4/48.2 Wh (90%) 
CPU:       Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP L2 cache: 2048 KiB 
           Speed: 1223 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1223 2: 1223 3: 1222 4: 1222 5: 1222 6: 1222 7: 1396 
           8: 1305 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nouveau v: kernel 
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso driver: amdgpu v: kernel 
           Display: x11 server: Fedora Project X.org 1.20.6 driver: modesetting FAILED: ati unloaded: fbdev,vesa 
           resolution: 1920x1080~120Hz 
           OpenGL: renderer: AMD RAVEN (DRM 3.36.0 5.5.5-200.fc31.x86_64 LLVM 9.0.0) v: 4.5 Mesa 19.2.8 
Audio:     Device-1: NVIDIA driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.5.5-200.fc31.x86_64 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp2s0 state: down mac: 04:d4:c4:e2:d9:a1 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter driver: rtw_pci 
           IF: wlp4s0 state: up mac: 80:91:33:c8:f1:19 
Drives:    Local Storage: total: 476.94 GiB used: 23.86 GiB (5.0%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW512G8 size: 476.94 GiB 
Partition: ID-1: / size: 60.08 GiB used: 12.15 GiB (20.2%) fs: ext4 dev: /dev/dm-0 
           ID-2: /boot size: 975.9 MiB used: 349.5 MiB (35.8%) fs: ext4 dev: /dev/nvme0n1p6 
           ID-3: /home size: 29.33 GiB used: 11.33 GiB (38.6%) fs: ext4 dev: /dev/dm-2 
           ID-4: swap-1 size: 7.78 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
           GPU: device: nouveau temp: 34 C device: amdgpu temp: 37 C 
Info:      Processes: 274 Uptime: 12m Memory: 7.64 GiB used: 2.60 GiB (34.0%) Shell: bash inxi: 3.0.37

I wonder if the problem is related to modsetting FAILED under the Graphics component.

“unloaded: modesetting” means the modesetting driver was unloaded after your secondary card driver got successfully loaded, (i.e) amdgpu, nvidia etc…
So not a concern.

please don’t stone the noob for saying, “me too”.
Attached inxi if that helps.
So far, when I have a brand new install, kernel 5.3.7, suspend (closing lid) “mostly works” especially when plugged in, things go back to normal when I open the lid again. After I updated to a new kernel (5.4.19), the system freezes when I open the lid, no kbd, touchpad, etc.
When on battery, suspend doesn’t. Either way I seldom have a clean system off, the system hanging at some last line. I’ll go open my own thread, just wanted to mention that this suspend issue might not be related to Nvidia at all, but something else?

inxi -F -G -M
  Host: localhost.localdomain Kernel: 5.3.7-301.fc31.x86_64 x86_64 bits: 64 
  Desktop: Xfce 4.14.2 Distro: Fedora release 31 (Thirty One) 
  Type: Laptop System: Hewlett-Packard product: HP EliteBook 2740p v: N/A 
  serial: <root required> 
  Mobo: Hewlett-Packard model: 7007 v: KBC Version 39.36 
  serial: <root required> BIOS: Hewlett-Packard v: 68COU Ver. F.04 
  date: 03/08/2011 
  ID-1: BAT0 charge: 23.5 Wh condition: 24.4/24.4 Wh (100%) 
  Topology: Dual Core model: Intel Core i5 M 560 bits: 64 type: MT MCP 
  L2 cache: 3072 KiB 
  Speed: 1410 MHz min/max: 1199/2667 MHz Core speeds (MHz): 1: 1414 2: 1288 
  3: 1453 4: 1447 
  Device-1: Intel Core Processor Integrated Graphics driver: i915 v: kernel 
  Display: x11 server: Fedora Project X.org 1.20.6 driver: modesetting 
  unloaded: fbdev,vesa resolution: 1280x800~60Hz 
  OpenGL: renderer: Mesa DRI Intel Ironlake Mobile v: 2.1 Mesa 19.2.8 
  Device-1: Intel 5 Series/3400 Series High Definition Audio 
  driver: snd_hda_intel 
  Sound Server: ALSA v: k5.3.7-301.fc31.x86_64 
  Device-1: Intel 82577LM Gigabit Network driver: e1000e 
  IF: enp0s25 state: down mac: 1c:c1:de:c2:91:c7 
  Device-2: Intel Centrino Advanced-N 6200 driver: iwlwifi 
  IF: wlo1 state: up mac: 18:3d:a2:99:c5:dc 
  Local Storage: total: 119.24 GiB used: 62.88 GiB (52.7%) 
  ID-1: /dev/sda vendor: LITE-ON model: LMH-128V2M-11 MSATA 128GB 
  size: 119.24 GiB 
  ID-1: / size: 29.40 GiB used: 10.97 GiB (37.3%) fs: ext4 dev: /dev/dm-0 
  ID-2: /boot size: 975.9 MiB used: 168.8 MiB (17.3%) fs: ext4 
  dev: /dev/sda1 
  ID-3: /home size: 83.70 GiB used: 51.75 GiB (61.8%) fs: ext4 
  dev: /dev/dm-2 
  ID-4: swap-1 size: 2.70 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-1 
  System Temperatures: cpu: 49.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 212 Uptime: 37m Memory: 7.57 GiB used: 1.65 GiB (21.8%) 
  Shell: bash inxi: 3.0.37
1 Like

@major @cristobal
Did your problem happen right away when you installed Fedora? or did it start not working after you did an update?

I am asking because I have exactly the same thing - no resume after suspend - but only when running a new kernel, after an update/upgrade. If I select the old kernel 5.3.7 in GRUB during boot, things “mostly work”, sometimes I don’t get suspend when closing the lid, system stays ON, but when it does suspend, system resumes normally after opening lid and flicking the power button, no freeze
BTW, I don’t have Nvidia, and I respectfully don’t think Nvidia is the problem, though we all know Nvidia has had a lot of issues in Linux, been there :slight_smile:

To avoid having to select the old kernel manually every time, this is what I did, might work for you or not:
rpm -qa \*kernel-core\*
gives me a list of kernels I have, like this:

Then, to remove the one I don’t want,
sudo dnf remove kernel-core-5.5.7-200.fc31.x86_64

From now on, the system will boot automatically to the old kernel

Of course this is not a solution, just a way to keep going until this problem gets solved. Best to y’all!

As I mentioned earlier, this behavior appeared only after the kernel got updated to 5.5.5
Since I sure I’m not the only one in this situation, I’ll wait for upstream to fix this.

Updating to kernel 5.5.7 now. Will post in sleep has been restored.

you’re quite right that this problem is showing up all over, if you do a search for “Fedora” “suspend” you’ll see something like this showing up from F29 on, and also in other OSs (ArchLinux, Centos). Apparently tablet people have this also. I would be curious if 5.5.7 works for you. I tried, didn’t work for me.

There is a suggestion about downgrading systemd, and then upgrading kernel, as if the problem actually might be with systemd and not in the kernel. I will try that. My memory is that there was a time when suspend worked flawlessly, at least for me, and then not anymore… Oh well, we’ll see. Thank you

I recently got a new laptop, and installed Fedora on it. I naturally assumed that it was because of the NVidia graphics since my previous laptop was AMD and everything worked flawlessly. However, I do have to say earlier I used GNOME and this time I am trying out KDE Plasma. So, maybe it’s related to KDE (if you people are also using KDE)…

This might be a kernel issue, but I don’t know how to log the issues such that it can be reported to the devs. journalctl?

Nope, 5.5.7 didn’t do it.

In my experience with Fedora, around the time of releasing a beta for an upcoming version, all sorts of minor annoyances crop up. Historically this was about the time I would try another distro, and would return to Fedora a few versions later. This time I’m staying put, for the simple reason that I have a shared wireless Epson printer and with other distros it is a nightmare to configure this printer, whereas with Fedora it is a breeze.

This might interest you. Today I have installed Fedora 32 KDE beta, it comes with kernel 5.6 rc5,
suspend not works.

So sorry for the typo. Should read suspend works!



F32 beta fixes the suspend issue for me as well…

Hi all, I’m new to Ask Fedora, but non so new about Fedora or linux in general. Anyway, as I’ve been far from the linux world for some time (few years…) and I came back with Fedora 30 KDE, now I need some help.
I’m having an issue when resuming from suspend to ram soon after the upgrade process from 31 to 32. Maybe it’s useful to say I upgraded from 30 to 31 without any issue and then thi s happened the other day after going from 31 to 32.
The only solution I found is to use the erlier kernel 5.5.17-200.fc31.x86_64 for Fedora 31.
Is there a way I can go back to use the actual kernel and solve the suspend/resume issue?
Thank you.

EDIT: I just tried the 5.6.8 and 5.5.18 kernels and I these are the dmseg errors I get with the 5.6.x serie (when resume after suspend doesn’t work) that I don’t see with 5.5.18:

[ 14.222988] sony_laptop: Invalid acpi_object: expected 0x1 got 0x3
[ 14.224223] sony_laptop: Invalid acpi_object: expected 0x1 got 0x3
[ 14.226409] sony_laptop: Invalid acpi_object: expected 0x1 got 0x3
[ 14.227001] sony_laptop: Invalid acpi_object: expected 0x1 got 0x3
[ 14.228061] sony_laptop: Invalid acpi_object: expected 0x1 got 0x3
[ 14.228063] sony_laptop: couldn’t set up lid resume function (-5)
[ 14.228305] sony_laptop: Invalid acpi_object: expected 0x1 got 0x3
[ 14.228306] sony_laptop: couldn’t to read the thermal profiles
[ 14.228307] sony_laptop: couldn’t set up thermal profile function (-22)