Unable to resume after suspend/sleep

I am having this problem with Fedora 32. It is extremely annoying to have to reboot every time it goes to sleep. Ctrl-Alt-F2/F1 does not help. Originally started with Gnome desktop, then installed KDE to see if that helped, to no avail.

System: Host: jva-linux Kernel: 5.6.14-300.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Distro: Fedora release 32 (Thirty Two)
Machine: Type: Desktop System: LENOVO product: 30BE006WMT v: ThinkStation P520
serial: <superuser/root required>
Mobo: LENOVO model: 1036 v: SDK0Q40112 WIN 3305670022602 serial: <superuser/root required>
UEFI: LENOVO v: S03KT36A date: 12/23/2019
CPU: Topology: Quad Core model: Intel Xeon W-2123 bits: 64 type: MT MCP L2 cache: 8448 KiB
Speed: 1200 MHz min/max: 1200/3900 MHz Core speeds (MHz): 1: 1200 2: 1200 3: 1200 4: 1200 5: 1201
6: 1201 7: 1201 8: 1201
Graphics: Device-1: NVIDIA GP106GL [Quadro P2000] driver: nouveau v: kernel
Display: x11 server: Fedora Project X.org 1.20.8 driver: modesetting unloaded: fbdev,vesa
resolution: 1: 2560x1440~60Hz 2: 2560x1440~60Hz
OpenGL: renderer: NV136 v: 4.3 Mesa 20.0.7
Audio: Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
Device-3: Microsoft Microsoft LifeCam Studio type: USB
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo
Sound Server: ALSA v: k5.6.14-300.fc32.x86_64
Network: Device-1: Intel Ethernet I219-LM driver: e1000e
IF: eno1 state: up speed: 1000 Mbps duplex: full mac: a4:ae:11:19:af:b9
IF-ID-1: virbr0 state: down mac: 52:54:00:b5:a5:ec
IF-ID-2: virbr0-nic state: down mac: 52:54:00:b5:a5:ec
Drives: Local Storage: total: 238.47 GiB used: 18.24 GiB (7.6%)
ID-1: /dev/sda vendor: Samsung model: MZ7LH256HAJD-000L7 size: 238.47 GiB
Partition: ID-1: / size: 68.40 GiB used: 12.61 GiB (18.4%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 975.9 MiB used: 238.6 MiB (24.4%) fs: ext4 dev: /dev/sda5
ID-3: /home size: 75.84 GiB used: 5.37 GiB (7.1%) fs: ext4 dev: /dev/dm-2
Swap: ID-1: swap-1 type: partition size: 7.68 GiB used: 0 KiB (0.0%) dev: /dev/dm-1
Sensors: System Temperatures: cpu: 39.0 C mobo: N/A gpu: nouveau temp: 36 C
Fan Speeds (RPM): N/A gpu: nouveau fan: 2056
Info: Processes: 313 Uptime: 30m Memory: 15.23 GiB used: 2.31 GiB (15.2%) Shell: bash inxi: 3.1.00

Hi, it has nothing to do with none of the things mentioned above. IT’S A KERNEL PROBLEM. I’ve passed this problem for a long time. Resuming after suspend works ok but I always lost the keyboard when doing so (the keyboard turns unresponsive after resuming from suspend to RAM). I’ve tested on 5 laptops with ALL Linux distribuitons: Arch, Mint, Fedora, Ubuntu, KDE, Zorin, etc. And, to have the proof, installed Windows too on this computers, and guess what? EVERYTHING WORKED FLAWLESSLY, so, no hardware problem. Another proof is that i used Ubuntu Mate 16.04 and didn’t have this problem. One day the kernel have been updated: the problem appears. Sadly, there is no universal workaround or temporary fix, i’ve tried everything: kernel boot parameters, increasing swap memory, display, installing another kernel, keyboard, etc, NOTHING RESOLVED. You won’t face this problem on desktop (at least on the majority of them, cause they use external keyboard). For me, I discovered that on my personal laptop, when the computer is resuming, pressing the “CapsLock” key wakes the keyboard (don’t ask me why, I don’t know why this happens), I only know it functions and works very well, so I have fully functional resume/suspend PC. In my case was the keyboard, but trough all my “Linux using life” I’ve seen a lot of issues and people complaining about suspend/resume in all communities. It’s a kernel problem that appears a time ago and yet they didn’t fixed. So annoying.

1 Like

Hi, this workaround works for my F32.
https://bugzilla.redhat.com/show_bug.cgi?id=1795422#c5

2 Likes

/etc/default/grub

grub boot option no_console_suspend can help. Don’t forget update grub.

For me it was help: screen after resume not blank and seen a lot of debug info and after that normal lock screen after change config

Also I make sudo dnf install acpid

sudo systemctl enable acpid && sudo systemctl start acpid

Linux laptop 5.10.2-200.fc33.x86_64 #1 SMP Mon Dec 21 17:37:11 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Thisis a fresh install of fedora 34 with gnome 40 and suspend remains an issue… anyone with a solution? thanks in anticipation

System:
Host: fedora Kernel: 5.14.11-200.fc34.x86_64 x86_64 bits: 64
Desktop: GNOME 40.4 Distro: Fedora release 34 (Thirty Four)
Machine:
Type: Laptop System: LENOVO product: 81UT v: Lenovo IdeaPad S145-15API
serial:
Mobo: LENOVO model: LNVNB161216 v: SDK0Q55724WIN
serial: UEFI: LENOVO v: BUCN29WW date: 05/14/2021
Battery:
ID-1: BAT0 charge: 31.3 Wh (94.3%) condition: 33.2/35.0 Wh (94.8%)
CPU:
Info: Dual Core model: AMD Ryzen 3 3200U with Radeon Vega Mobile Gfx
bits: 64 type: MT MCP cache: L2: 1024 KiB
Speed: 1394 MHz min/max: 1400/2600 MHz Core speeds (MHz): 1: 1394 2: 1800
3: 1397 4: 1932
Graphics:
Device-1: AMD Picasso driver: amdgpu v: kernel
Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
Display: wayland server: X.Org 1.21.1.2 driver: loaded: amdgpu
note: n/a (using device driver) - try sudo/root resolution: 1920x1080~60Hz
OpenGL: renderer: AMD Radeon Vega 3 Graphics (RAVEN DRM 3.42.0
5.14.11-200.fc34.x86_64 LLVM 12.0.1)
v: 4.6 Mesa 21.1.8
Audio:
Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.14.11-200.fc34.x86_64 running: yes
Sound Server-2: PipeWire v: 0.3.38 running: yes
Network:
Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
driver: ath10k_pci
IF: wlp2s0 state: up mac: 74:4c:a1:a8:8f:37
IF-ID-1: virbr0 state: down mac: 52:54:00:b9:8e:70
Bluetooth:
Device-1: Qualcomm Atheros type: USB driver: btusb
Report: rfkill ID: hci0 state: up address: see --recommends
Drives:
Local Storage: total: 1.14 TiB used: 125.29 GiB (10.7%)
ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
size: 238.47 GiB
ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-24Z10
size: 931.51 GiB
Partition:
ID-1: / size: 236.89 GiB used: 8.44 GiB (3.6%) fs: btrfs
dev: /dev/nvme0n1p3
ID-2: /boot size: 975.9 MiB used: 207.6 MiB (21.3%) fs: ext4
dev: /dev/nvme0n1p2
ID-3: /boot/efi size: 598.8 MiB used: 16.2 MiB (2.7%) fs: vfat
dev: /dev/nvme0n1p1
ID-4: /home size: 236.89 GiB used: 8.44 GiB (3.6%) fs: btrfs
dev: /dev/nvme0n1p3
Swap:
ID-1: swap-1 type: zram size: 5.66 GiB used: 9 MiB (0.2%) dev: /dev/zram0
Sensors:
System Temperatures: cpu: 51.1 C mobo: N/A gpu: amdgpu temp: 51.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 393 Uptime: 2h 49m Memory: 5.66 GiB used: 3.01 GiB (53.2%)
Shell: Bash inxi: 3.3.06

You are posting on a thread that is 18 months old.

Please open a new thread for your issue.
It is fine to reference this thread but yours should be new since the version of fedora is newer and lots of things have changed in the last 1 1/2 years.