Touchscreen not working after waking from suspend | F40 |

My laptop (Dell Latitude 7310) has a touchscreen and it works perfectly as soon as it enters suspend mode. After waking the laptop, the touchscreen does not work at all no matter what I do. I have noticed this happening only after I switched /sys/power/mem_sleep to deep. When it was set to s2idle the touchscreen worked fine after waking.

I read a few other threads regarding similar issues and tried the following without any luck:

  • Changing the suspend mode in BIOS from Linux to Windows (I have no such option)
  • Disabling Thunderbolt 3
  • Reloading the hid_multitouch and wacom kernel modules
  • Using xinput enable/disable for the touchscreen (I use Wayland but I tried it in X11 too)

I should also note that in Gnome settings under the Wacom tablet section it detects no devices.
Is there something I need to configure differently to fix this?
I can provide any hardware information necessary or any logs. Thanks in advance!

Added f40, intel, workstation and removed gnome, wayland

Welcome to :fedora:

I would typically ask, what kernel version you are on, and post your hardware info with inxi -Fzxx , but it looks like you’ve done some tinkering already. . .

Is this a setting you can revert, since it was working prior to your change?

Thanks for the reply!

Here is the output if it helps:

  Kernel: 6.9.6-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
  Type: Convertible System: Dell product: Latitude 7310 v: N/A
    serial: <superuser required> Chassis: type: 31 serial: <superuser required>
  Mobo: Dell model: 00N7RN v: A00 serial: <superuser required> part-nu: 09CC
    UEFI: Dell v: 1.30.0 date: 04/08/2024
  ID-1: BAT0 charge: 33.2 Wh (99.4%) condition: 33.4/51.0 Wh (65.5%)
    volts: 8.1 min: 7.6 model: BYD DELL HRGYV0A serial: <filter>
    status: charging
  Device-1: hidpp_battery_0 model: Logitech M215 serial: <filter>
    charge: 55% (should be ignored) status: discharging
  Info: quad core model: Intel Core i7-10610U bits: 64 type: MT MCP
    arch: Comet/Whiskey Lake note: check rev: C cache: L1: 256 KiB L2: 1024 KiB
    L3: 8 MiB
  Speed (MHz): avg: 943 high: 4750 min/max: 400/4900 cores: 1: 400 2: 400
    3: 400 4: 400 5: 4750 6: 400 7: 400 8: 400 bogomips: 36799
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1,
    HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:9b41
  Device-2: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-6:2 chip-ID: 0bda:5539
  Display: wayland server: v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: InfoVision Optronics/Kunshan 0x8544 res: 1920x1080
    dpi: 166 diag: 337mm (13.3")
  API: OpenGL v: 4.6 vendor: intel mesa v: 24.1.2 glx-v: 1.4 es-v: 3.2
    direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
    device-ID: 8086:9b41 display-ID: :0.0
  API: Vulkan v: 1.3.283 surfaces: xcb,xlib,wayland device: 0
    type: integrated-gpu driver: N/A device-ID: 8086:9b41 device: 1 type: cpu
    driver: N/A device-ID: 10005:0000
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
  Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:02c8
  API: ALSA v: k6.9.6-200.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
  Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:02f0
  IF: wlo1 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Local Storage: total: 238.47 GiB used: 126.02 GiB (52.8%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2200S NVMe 256GB size: 238.47 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 38.9 C
  ID-1: / size: 236.87 GiB used: 125.62 GiB (53.0%) fs: btrfs dev: /dev/dm-0
    mapped: luks-229f51db-6b75-42a9-8149-fc6d97a1febe
  ID-2: /boot size: 973.4 MiB used: 356.3 MiB (36.6%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 54.2 MiB (9.0%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 236.87 GiB used: 125.62 GiB (53.0%) fs: btrfs
    dev: /dev/dm-0 mapped: luks-229f51db-6b75-42a9-8149-fc6d97a1febe
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 55.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Memory: total: 16 GiB note: est. available: 15.29 GiB used: 3.49 GiB (22.8%)
  Processes: 422 Power: uptime: 6h 23m wakeups: 5 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 52 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: gjs inxi: 3.3.34

Yes, I can change this setting between s2idle and deep. By default it is set to s2idle but this drained a lot of battery when suspended so I had to use deep (which from what I read suspends to RAM). In fact I did change it back to s2idle before posting this to verify that this behavior was exclusive to the deep suspend mode.