Touchscreen not responsive in new kernel 5.8.4-200

I am using a Cherry Trail convertible tablet (Acer One 10). On a fresh install of Fedora 32, the touchscreen functions normally; however, after upgrading to the latest kernel the touchscreen does not generate response at all.

Details: I can still manually boot into kernel version 5.6.6-300.fc32.x86_64, and the touchscreen continues to work normally. When I boot into kernel version 5.8.4-200.fc32.x86_64 the touchscreen does not work at all; I can still interact with the system using the removable keyboard and trackpad. I have not had the opportunity to try any of the intervening kernels that might have been released between these two.

For the short term, I could pin that older kernel version to keep the touchscreen working, but I’m afraid it won’t be viable over the longer term.

Were there any known changes which might explain the loss of the touchscreen in the newer kernel? Are there any strategies I might take to restore its operation?

1 Like

This seems to be a regression in a recent kernel. What about all those kernels between the 5.6.6 and the current current? Have you installed/tried those?

I would suggest the following:

1.) Try the newest 5.8.5 from koji to see if the problem has already been fixed
2.) Try the lastest 5.7. kernel (should be 5.7.17:
3.) Report a bug if the problem persists: How to file a bug :: Fedora Docs
4.) Stick to the older kernel until the problem is fixed, keep testing every new kernel (It may be necessary to increase the number of kernels your system keeps installed on updating the kernel package)

re 1.) from an empty/new directory, use the following for downloading 5.8.5

koji download-build --arch=x86_64 kernel-5.8.5-200.fc32

then run from that directory: sudo dnf install kernel*


Thank you for the advice; I wasn’t previously aware of where to look for access to older released kernels to try them out, so previously I had only tried the 5.6.6 kernel that came with the install image, and the 5.8.4 kernel that was immediately offered to me the first time I checked for updates.

After manually installing the 5.7.17 kernel, I can confirm that the problem was also present there. I will try going back to try some other kernels that might have been released between 5.6.6 and 5.7.17 to see if I can figure out when the problem first started.

I will report back as I have opportunities to perform more tests.

1 Like

Tested this out on a Dell Inspiron 7573 2-in-1. I also had issues with the touchscreen not working on 5.8.4-200.fc32.x86_64. I followed florian’s advice to test out 5.8.5 and installed via the instructions given. Rebooted and now the touchscreen works. Confirmed that it did update to 5.8.5.

1 Like

I also got an Acer One 10 (S1003).
Touchscreen is still not working in 5.8.15 for me.

Affected users should report a bug and let developers know…

1 Like