Touchpad dont work after suspended

I have the SYNA 3602 touchpad (Vaio FE14, notebook), that is known for have some issues with linux kernel. However, It’s getting better after every new update of kernel (I’m using the kernel 5.16.5-200.fc35).
Anyway, the touchpad don’t work after suspension of the computer, even if I restart the module with sudo modprobe -r i2c_hid_acpi && sudo modprobe i2c_hid_acpi, and doesn’t matter how many times I do, it doesn’t works. By the way, even though it don’t work after suspension the system recognizes it by sudo libinput list-devices but not with cat /proc/bus/input/devices.

  1. I already saw some shell scripts and workarounds for manjaro-linux that does the same as the commands
  2. The touchpad works after every shuting down completely the system, but not with reboot. And, if the touchpad don’t work in the initialization - sometimes happen -, I restart the modules one time and it works properly. If I suspend or reboot it won’t work.
    Any help, I will be grateful :smiley:

I’m not sure, but maybe you also want to check with xinput. On terminal type xinput and enter, then find the id=x of your touchpad, let say it’s id=15 [slave piointer (x)] then try with xinput --disable 15 then enable again with xinput --enable 15.

Thanks for your help, I appreciated that.
I already tried it and nothing change. I filed a bug report in bugzilla, maybe it helps in future.

1 Like

Sorry, I guess I’m quite late for the party. Did you already solve that problem? If not, does the touchpad get recognized after your pc got suspended? (Yes, I read that it got “partly” recognized, but since you asked that question quite a while ago, I think it could be different by now)

It’s a problem with the linux kernel, and, more precisely, the acpi module. I have problems with the suspension either, besides this touchpad issue. But yes, the system recognizes it in the /proc/bus/input/devices and in libinput list-devices. but only this, it’s just recognizable. In rare events, like 1 in 100, in kernel 5.16 and 5.17, it work after a suspension.

Thanks for the reply. If it’s - like you said - a problem with the kernel, I think your best option is to just wait until the problem gets solved… Have a nice day, I hope it will get fixed soon!

Funny thing it was happening every now and then till I saw this page and now it happens with me every time I suspend my lenovo thinkpad laptop.
Any luck solving this.

One last thing to add is that I can suspend once now. After that it wont suspend again, in addition ofcourse the touchpad wont work ending up with using a USB mouse to avoid a reboot.

Can you print the output of this commands? sudo lsinitrd | grep resume
sudo cat /etc/systemd/logind.conf
cat /etc/systemd/sleep.conf


Please check the below

sudo lsinitrd | grep resume


sudo cat /etc/systemd/logind.conf

All commented except [Sleep]

cat /etc/systemd/sleep.conf

All commented except [Login]

What changed it was working fine before 2 weeks.

Dear @davijbvasconcelos

Seems that this is faced when booted to kernel 5.17 and not faced in kernel 5.16.

I do confirm that its a bug in kernel 5.17.4-200.fc35.x86_64

Thank you.

Please, @egassem, report this bug to bugzilla.

And If I understand your problem correctly, after a suspension your system goes for a reboot. Is that so?

  1. I do not know a solution for the touchpad issue, but you can try restarting the module sudo modprobe -r i2c-hid-acpi && sudo modprobe i2c-hid-acpi. If this make the touchpad work, you can try a workaround, look for some tutorials.

  2. I faced a similar problem (with suspension itself) in my notebook and I had to make some changes. First, uncomment (deleting the # before the content) the lines AllowSuspend=yes and SuspendState… (Did you faced any problems with suspension by closing the lid? See this page: SystemdSuspendSedation - Debian Wiki)
    Second, try add the resume module by using dracut: sudo dracut -vf -a resume and see if it works. If positive, echo 'add_dracutmodules+="resume"' > /etc/dracut.conf.d/99-fix-resume.conf && sudo dracut -vf to make the resume module permanent.

Dear @davijbvasconcelos

Nope it does not go to reboot. It stays up it wont go to suspend

No luck didnt work.

Cant say its a configuration problem. Knowing that when booting to old kernel it works fine.
Thank you.

I have same exact problem of egassem. I am able to suspend once. After resuming suspension, touchpad stops working and I’m unable to suspend again. When I try to suspend one more time, screen goes black for half a second, then it returns to unlock screen (it does not log me off). Same problem with hybernation.

Just one question could you please send the output of uname -a

hey, could you print the output of sudo lsinitrd | grep resume booted in the old kernel?

Still nothing I sticking to my initial guess its the new kernel.
Did any one report a bug on this or we are the first ones to fine it.

I have updated kernel to 5.17.5 and still issue faced.

1 Like

Quick update on this suspen issue that we are facing. I updated to fedora 36, using at this time kernel 5.17.5-300 and it is working flawless. I hadn’t one single problem with suspension since I rebooted the notebook after the installation.
I’ve noted some changes in the grub file, were added this parameters: GRUB_CMDLINE_LINUX=“resume=UUID=71a3f20c-3eca-4d69-b172-ae3b2700fa60 rhgb quiet”
that weren’t in my fedora 35.

The touchpad still not working even if i restart the modules

it will be released officially on the 10th of this month. probably we should do it