Timeshift in Fedora 35


I installed Timeshift via the Copr repository. It worked initially but has recently stopped working. I can open the GUI and see historic snapshots on my USB hard drive but am unable to create new ones.

I would appreciate advice on how to get it working again, or a recommendation of another system backup tool to use. I would like to be able to do a backup before upgrading to Fedora 36. Thank you in advance!


1 Like

You don’t need copr repo anymore. I shipped latest version for F35 and above versions.

1 Like

I have followed the steps, but I am unable to add to my backup drive, nor delete, as if it has been rendered read-only. What action do I need to take next?

Check the space available on the backup drive, as well as the permissions and how it is mounted. If it is full it could not be written to. If it is mounted as ro then it cannot be altered. If it is owned by root and you are attempting to alter it as a regular user that does not work.

We really need details. The comment I have followed the steps does not tell us anything about what is happening. What steps? What commands? What messages do you get? We can only guess!

As @thunderbirdtr told timeshift is already on main repo no need to install it from copr uninstall that first then disable that repo and install it from the normal repo

After disable copr repo then run dnf clean all
And then dnf update and then install it everything should go well
Install timeshift with
sudo dnf install timeshift

1 Like

Also, Timeshift require “certain” partition settings, and sometimes it could be not compatible what we have (technically upstream needs to take look as well)

Quote from their github project page (GitHub - teejee2008/timeshift: System restore tool for Linux. Creates filesystem snapshots using rsync+hardlinks, or BTRFS snapshots. Supports scheduled snapshots, multiple backup levels, and exclude filters. Snapshots can be restored while system is running or from Live CD/USB.)

In BTRFS mode, snapshots are taken using the in-built features of the BTRFS filesystem. BTRFS snapshots are supported only on BTRFS systems having an Ubuntu-type subvolume layout (with @ and @home subvolumes).

1 Like

To clarify, steps taken:

Timeshift removed
Copr repository disabled
Sudo dnf clean all ran
Sudo dnf install Timeshift ran - installed from upgrade repo
Timeshift GUI opened - status message Timeshift is active
Still no success at creating a snapshot

Additional information:

41 snapshots rsync
418.6 GB available