I can't install timeshift on Fedora 35

When i try to install Timeshift on Fedora 35 it says that i already have downloaded it. However, when i browse for timeshift in my applications i cant find it.

Also: I did install Timeshift before without adding the Fedora 35-specific repo, but the program didn’t work correctly, so I removed it.

This screenshot doesn’t show any errors - it just shows that the RPM has been downloaded before and is still in the cache. The lines after this should show the actual installation.


Also: timeshift is available in the Fedora repositories. Is there a reason you are installing it from a COPR repository?

PS: can you please:

  • paste text instead of screenshots (we can’t search for text in screenshots)
  • run your commands with LC_ALL=C ... to get the outputs in English?

Was there any additional info displayed after the [SKIPPED] line?

That is a normal response for any package that has been downloaded and remains in the cache.

If it did not install then you can do this to clean up the cache then download it again and install it.

sudo dnf clean all 
(which will clean all the dnf cache and metadata)
sudo dnf clean packages
(which will remove all the cached packages so everything downloaded is new.)

followed by

sudo dnf install timeshift

A little bit of background.
Timeshift is in the Fedora repository but until some time ago, it was not updated since the times of the release of Fedora Linux 35. So it was not working and someone created a COPR repository with the latest (working) upstream version.
A non responsive maintainer process started some time ago and just recently another packager come up and took care of the package in the Fedora repository: currently the new package is in the updates testing repository.


Superb! It worked after running

sudo dnf clean all 



I had a very similar issue on F36 today. I was updating the system and dnf would not do anything except telling me that the packages have already been downloaded. dnf clean all fixed it.
There may be some dnf bug be around.


A post was split to a new topic: Trouble with timeshift