T480s sometimes does not boot up with Fedora 40


Hi! I’m a newbie in the Fedora (and Linux) world. I installed Fedora 40 on my Thinkpad T480s and have been amazed by the result. Although, there is (what I think is) a bug which drives me crazy.
Every night I shut down the laptop (which has around 50-60% of charge) and in the morning I try to boot it up, but it doesn’t completely boot up.
The manufacter logo shows, the Fedora logo appears and starts loading and after a few seconds it shuts down. I try multiple times but it doesn’t boot up, then I plug in the charger and magically it boots up completely.

Do you have any idea? How can I get help?

Hello paperino

I have some questions to ask you. With them, try to review your steps during the first installation:

1- Is your notebook’s BIOS configuration the default (UEFI+Secure Boot + TPM2.0)?

2- By what method did you create your bootable pendrive (Rufus, Fedora Media Writer, Ventoy, MedCat, Balena Etcher, etc.)?

3- Did you try to reinstall the system with a new Fedora 40 ISO image? (it is normal for the first releases to contain minor bugs).

4- During installation, did you enable third-party / “non-free” software installation permission and its repositories? (it is strongly recommended to activate this permission).

5- Was the installation online or offline? (strongly recommended online).

Try redoing your system once again by completely erasing the existing disk and partitions and rethinking each step of the procedure if you don’t have any important files on it. If there is, make a backup before).

PS- Don’t worry about being a “newbie”. We all still are, we have a lot to learn and we will die knowing almost nothing. :rofl:

1 Like

What does the charge level show when the boot issue is occurring and at the time you plug in the charger.

To me this sounds perfectly normal for a laptop with a battery that is low in charge.

Was the laptop put into suspend instead of powered off? This would continue to drain the battery overnight.

I tested it with the battery full, same problem. So I checked the battery integrity, both yesterday and today. Yesterday was at 82% health and after today’s update it dropped to 70% health. Maybe it’s dying…

This is a typical problem with older batteries that have reduced ability to meet peak power demands. Sometimes a contributing factor is heavy processing (e.g., fsck due do to “unsafe” shutdown) starting at boot – at work (a decade ago) we were given the use of a system that was configured to run a big numerical code when otherwise idle. When the system booted it loaded the model which immediately maxed out all CPU’s (because no user was logged in) and tripped the UPS overload. We had to move it to a machine room with a much large UPS until we were allowed to remove the numerical model.

Until the problem is fixed you should avoid booting without the charger as it may cause an unsafe shutdown and risks damage to filesystems.

There are tools (e.g, upower in a terminal to display the battery condition. You can use journalctl --no-hostname -b <N> to compare messages from a boot that fails with one that was successful. I would start with journalctl --no-hostname -b -g fsck | cat to see if file system checks (fsck) are finding problems. You can use Gnome Disks to check drive health, to see if the number of “unsafe shutdowns” is growing.

1 Like

So I took a look at the battery status and yea, after 500 cycles it was definitely going to die. So I ordered a new one and tried it. It solved the problem. Thanks a lot and thanks to everyone else for the support!