Steam for Silverblue

packaging

#1

Hey,

is there already a version of steam which is suitable for Silverblue?


#2

Does this one not work for you?

https://flathub.org/apps/details/com.valvesoftware.Steam


#3

ah yes it works from flatpak :wink:


#4

I’ve found that sound doesn’t work, at least on some games, for example Endless Sky. (I know Endless Sky is itself available from Flathub and as a Fedora package, but I run it via Steam because I have a saved game there.)

I used to have Steam installed on Fedora 27 Workstation from a popular 3rd-party source; sound worked in Endless Sky (and other games). When I installed Steam from Flathub on Fedora 27 Workstation or on Silverblue 28, there’s no sound in Endless Sky (I haven’t tried other games yet).

Is sound working OK for you?


#5

Okay thx for sharing your experience and problems with the sound.

For me, I worked before on F28 workstation and I installed it from flathub Steam worked and I didn’t have any problems. On Silverblue I have to check it. I only downloaded and installed it :wink:

I hope to give my experience later on or tomorrow :slight_smile:


#6

I’m using Steam from Flathub (it’s already linked here). It works just fine.

But many users of flatpaked Steam from our Russian Fedora chat on Telegram reported weird gaming performance issues in compare to native Steam (package from RPMFusion). And my tests has confirmed that.

For now, before reporting my tests, I’m looking for a way to compare something different from Steam. Flatpaked benchmark vs native for example.


#7

Perhaps you could benchmark handbrake? There is a flatpak version available and it looks like it is available from RPMFusion.

You should be able to get some decent statistics on encoding media by comparing the two formats.


#8

CPU is not the issue. The issue is OpenGL performance. By some unknown reasons GPU rendering under sandbox is lazy, trying to minimize the GPU load instead of using it’s full potential (until it REALLY needs it, at least). The CPU load remained all the same on both tests.

I’ve tested it using Half-Life 2: Lost Coast. Yeah, it’s old, but on this example the problem become more clear. Because my configuration can give hundreds of FPS playing this game on maximum available settings. And it has it’s own GPU test scene. And I’ve compared the results also watching the Gallium HUD graph.

I’ve tried also to test this on Everspace, but it plays on about 25-40 FPS using Ultra graphics (it’s kind of maximum my notebook is capable of) and I wasn’t able to clearly see the problem, only mouse struggling.

Here is some screenshots:

^ Here is the native Steam. 172 FPS on average.

^ And here is sandboxed one. One game, one test. But 83 FPS in the average result. And look at the right graph.

In some places FPS lowers to unbelievable <30 FPS while in native game there was a hundred of FPS. Like this one:

And by something different from Steam I’ve meant a flatpaked Unigine Heaven, for example. But it doesn’t exist. Maybe I can make one in near future for testing purposes.

P.S. My config is