Issues with Kinoite and Steam (Flatpak)

So I have been running Silverblue for a bit and while I like GNOME well enough, I wanted to see if the grass was greener on the other side, with Kinoite. So I made sure I didn’t have any GNOME packages overlayed as this can cause issues, then I rebased on Kinoite. Everything went fairly well. There was only one problem…

Steam, installed via Flatpak, worked flawlessly (for a DRM platform…) on Silverblue. However, I could not keep it open on Kinoite. It would open, sometimes it wouldn’t even get all the way done a Steam client update before crashing. Just constant crashes.

I ran it from the command line and there was no specific error that occurred when the client crashed, and there was no error.log or similarly named files in the ~/.var/app/com.valvesoftware.Steam/ directory. It’s really strange because it works great in Silverblue.

Originally I thought it was because I rebased on the original Kinoite 35 release instead of /updates. But I tried again a couple days later with the updates tree and it still crashed. I removed the flatpak directory and that let it start for a little longer (it seemed at first glance) but it still crashed. I ended up deleting my entire games library (not a big issue, can just reinstall) trying to troubleshoot.

Is there perhaps a list of packages that are installed in Silverblue and in Kinoite perhaps? Maybe there’s something in the former that is missing in the latter.

I’ve seen this in the past but I have not investigated yet. For me it only crashed/exited before being logged in. Once I managed to log in, it never stopped. Hope that helps.