[SOLVED] /mnt/sysimage/boot/efi fails

Hi all, never used Fedora before but interested in the SilverBlue concept, and would like to have a closer look.
However I have a problem installing SilverBlue. All seems to go well until it wants to update the /boot/efi partition, when it gets an error. This is the last few lines of the program.log.
18:14:42,546 INF program: Running… systemd-tmpfiles --create --boot --root=/mnt/sysimage/ostree/deploy/fedora/deploy/982faf58087c9d020780b829d5f24b4e78bd40399b4e4769fc8bc2df9890e301.0 --prefix=/var/spool
18:14:42,569 DBG program: Return code: 0
18:14:42,570 INF program: Running… systemd-tmpfiles --create --boot --root=/mnt/sysimage/ostree/deploy/fedora/deploy/982faf58087c9d020780b829d5f24b4e78bd40399b4e4769fc8bc2df9890e301.0 --prefix=/var/spool/mail
18:14:42,593 DBG program: Return code: 0
18:14:42,594 INF program: Running… mount --bind /mnt/sysimage/home /mnt/sysimage/ostree/deploy/fedora/deploy/982faf58087c9d020780b829d5f24b4e78bd40399b4e4769fc8bc2df9890e301.0/home
18:14:42,605 DBG program: Return code: 0
18:14:42,606 INF program: Running… mount --bind /mnt/sysimage/boot/efi /mnt/sysimage/ostree/deploy/fedora/deploy/982faf58087c9d020780b829d5f24b4e78bd40399b4e4769fc8bc2df9890e301.0/boot/efi
18:14:42,618 INF program: mount: /mnt/sysimage/ostree/deploy/fedora/deploy/982faf58087c9d020780b829d5f24b4e78bd40399b4e4769fc8bc2df9890e301.0/boot/efi: mount point does not exist.
18:14:42,619 DBG program: Return code: 32

There are two other posts related to this problem, however the resolutions did not work for me, in fact they didn’t work at all. One suggestion was to use automatic partitioning. I was a bit confused by this as I had successfully gotten past the partitioning step and the OS had installed itself, the error occurred when it was trying to install the startup files in /boot/efi. I tried using automatic partitioning but it returned an error message that partitioning could not be completed, or words to that effect.

I have /boot/efi on sda1, linux Mint on sda2, and swap on sda3. I have a 2.7Tb usb disk attached to my PC, which is where I’m trying to install SilverBlue. It currently has three 500Mb partitions, the first two contain other linux distros, and I want to install SilverBlue in the third partition.
I have also tried creating a new ESP partition on the USB drive, but still get the same error.

How do I get past this problem? Can I manually install the /boot/efi files (assuming that the OS has correctly installed itself on my usb drive)?


The Silverblue installer needs a /boot as ext4 in order to work. I’ve personally found it easiest to select manual partitioning but then hit the button to have Anaconda auto-create all the partitions, then modify them as necessary.

1 Like

Thanks @refi64 I’ll try that. My email has been down for the last four days (ISP implementing a new system apparently. The cutover didn’t go that well…) so apologies for the tardy reply.

1 Like

Okay I now have Silverblue installed on my USB drive. I was not able to use the existing /boot/efi partition on the internal drive. When I tried that I a) could not use the automatic partitioner, it returned an error message saying partitioning could not be completed (or words to that effect, sorry I did not note the exact wording), and b) I could not allocate a /boot partition greater than 1024Kib. No matter what I tried the size would always revert back to 1024Kb. When I tried to proceed with the installation I received a warning that /boot was too small. (I think it said the minimum size was 200Mb.) At this point I gave up on that route.
I tried again but this time only selecting the USB drive, not the internal drive as well. This time I was able to allocate a /boot of 500Mb (pure guess on my part), but then thought I’d try the automatic partitioner. This time it worked, and allocated a /boot of 1024Mib. Seems like a lot, but what the heck, it’s a 2.7Tb drive. I changed the /home size to 400Gb (it had allocated all the remaining space on the drive) and started the install.
The install was successful, but when I rebooted it booted directly into Fedora. A grub error message flashed very briefly on the screen, not long enough for me to read it, and then Fedora booted.
I shut down and restarted, and entered the bios boot menu and removed the Fedora bootloader. I use Refind bootloader, so I put that one back on top. Rebooted again and Refind came up with all my distros including Fedora, so it appears it has no problem with multiple /boot/efi partitions.
So, happy days. Silverblue is up and running.
Thanks again to @refi64 who pointed me in the right direction.
:wink: Ian

That’s great to hear!

In your first case, most likely the size was reverting because all the other space on the disk was already taken by other partitions that were about to be created. You’d have to shrink one of the other mount points first

As for the grub error, I think you ran into this bug; there’s a fix in the second-to-last-comment.

Can I somehow overcome this requirement, at least after install?
I’m going to get rid of grub in favor of systemd-boot, so my /boot going to be on EFI ESP which is VFAT.
No symlinks should be needed in /boot according to Boot Loader Specification.

Can I achieve that?