F36 Silverblue Installation Fail

Thought I’d give Silverblue a try. Booted the USB, checked the iso and started the install. Everything went well until the actual install moved on to ‘Deployment starting… etc.’, then a quick fail with 'The command ‘ostree admin --sysroot=/mnt/image/deploy… etc. exited with code 1.’

I tried again with the same result. Any idea what might be going on?

You may want to take a look at this bug.

1 Like

Hello Joe,

Well, that looked like what I was seeing. I tried the workaround, but still no joy - same error. I will go through that thread more carefully to see if I can come up with something else to try.

Thanks much for the pointer to the bug report!

1 Like

I had the same error on a PC with Windows and a previous Fedora Workstation install.

This recommendation in that quite long bug report worked for me:

rm -r /boot/EFI/fedora

1 Like

Which recommendation helped you? The command? Where do I put it? In windows?

This message

So that didn’t work but I opened windows partition manager and deleted a small partition that said EFI and is was at the beginning of the disk I’m installing fedora on (it’s not a windows partition because it’s on a different drive). And it installed

Please note that when installing a new version of any OS that you should open your own new thread and post details of the problems you are encountering.

A good place to find info concerning the details required is here

The thread this is posted on was last accessed more than a year ago and is related to Fedora 36, which is 3 versions back and considerably behind in software and issues seen.

Luckily the repair with removing an older version of the /boot/efi/EFI/fedora (or in your case simply removing the entire partition) worked, but that may not always be the case.

Had your system been installed as normally recommended with both OSes (windows and fedora) sharing a single efi partition your actions would have destroyed the ability to boot windows without a repair or reinstall.